Firestore POST error with (custom) document id

From the last time i used this, something has changed, this is what it looks like

I cant understand what the Record properties does ?

Any help is appreciated

I also tried it this way,

and im getting this result

Do you know whats going on ?
Please help

As the error complaines about the JSON payload, I would recommend to look into the body of the http request. → “id” at 'document.

Thanks for the reply, you think that the url is correct?

As for the body, its this

But my question, is where should i put the id that i want the new document to have because in the past, there was no such thing as the record properties (from what i remember)

I assume that the Schema of the body isn’t right because it misses „fields“ and „stringValue“. The schema should be the same like in the response you receive after a GET request.

If you want to set a defined id, you place it in the url (like you already do).

I recommend to run it on to play around with the settings.

Hi as you might see, my request in postman is successful

but i still get the same error when using the this url in appgyver tester.

these are all, can you spot any errors, from what i can understand, the problem is in the request properties but i dont know how to set it up

Here is a screenshot, so you can see what I mean with “fields” and “stringValue”:

(according to your screenshot you created an empty document with postman; without any content (= empty body) the error doesn’t show up.)

Most convinient way to set the POST schema:

a) create a dummy document
b) run GET request
c) set schema from response
d) use GET schema for POST as well


1 Like

oh so youre saying that i need to create and update the document at the same time? because i was trying to create and then update it not both at the same time.

No, I didn’t mention an update of a document.

All you need is a valid schema for the POST request. And this schema you can either enter by hand or you can use the more “convinient way” by creating a dummy document directly in firebase and use this dummy for a GET request.

1 Like

Sure i totally get what you mean, as for the document update, i was the one that thought that was the right way, you was very helpful, thank you

Hey @stayfoolish unfortunately, trying to get the schema as you told me, i get this error, do you know what’s going on?

Actually i had this part of the request url wrong