Firestore POST to subcollection fails

I’ve got most of CRUD working on my Firestore main collections, including POST, through the Data Configurator. I’ve got subcollection document retrieval working - but when I go and try to POST a document into a subcollection (specifically, one that I can successfully get a collection and get a record from), it fails - even when I pattern it off of the successful POST of a top-level collection, and follow the path from the successful GET’s from the same collection I’m trying to POST to. I don’t get it… No documentation covers POSTing to subcollections - What simple thing am I missing?

It fails with a 400:

Error: JSON error response from server: {“error”:{“code”:400,“message”:“Invalid value at ‘document.fields[0].value’ (, “Jamey-Fighter”\nInvalid value at ‘document.fields[1].value’ (, 6\nInvalid value at ‘document.fields[2].value’ (, “run down tunnel””,“status”:“INVALID_ARGUMENT”,“details”:[{"@type":“",“fieldViolations”:[{“field”:“document.fields[0].value”,“description”:"Invalid value at ‘document.fields[0].value’ (, “Jamey-Fighter””},{“field”:“document.fields[1].value”,“description”:“Invalid value at ‘document.fields[1].value’ (, 6”},{“field”:“document.fields[2].value”,“description”:“Invalid value at ‘document.fields[2].value’ (, “run down tunnel””}]}]}}.status: 400

Resource settings for Create record (POST)

Resource URL:
Relative path: games/{gameID}/sessions/{SessionID}/events

From your link:

At this point, you could integrate to a subcollection by creating a REST API direct integration from the Data configurator, using the document ID as a URL placeholder.

This is what I think I’m doing. Maybe I don’t understand the terminology “direct integration” Could be why I’m stuck… I think I know what I’m doing, but I don’t.

I don’t want to use the array of objects - if that has to be a hack, I might as well return to SQL!

Looks like you are facing something else than I thought…
Can you please post a screenshot of your POST-schema and what values you are trying to put in?

Wow… I’m dumb. Thank you for forcing me to check my schema - I assumed too much and didn’t dig past glancing at it …and forgot they each had to be objects with their value as properties. Fixed it, and it worked straight away. Thanks!!!