Font remains as system default even when changed

When the font style and size is set the users system font still affects the app.

I realize that there’s an option for system default fonts and selected fonts however nothing changes. Android build 2.XX.

2 Likes

Hi! Sorry for the belated answer. I’m currently trying to verify this issue, and will send it forward to get fixed if I reproduce it.

Hi! I tested using custom fonts and had no trouble. Could you give me more info about your case? My setup was as follows:

Screenshot 2021-01-28 at 9.45.14
Title using a custom font (bound directly to Title)


Font, uploaded in Composer.

The issue was that, It shows up on the composer but not in the app and also when a user changes the font size on the phone the apps phone size changes. Can be that be stopped ?

Hi! Font size changing if user changes it in system fonts can’t be prevented at this point. But can you confirm that the custom font works for you now (it appears in your app)?

The custom font in my builds aren’t showing up either. They show up in preview but not in the build. But what I’ve noticed is that the “normal” font weight (400) does show up in the build! It’s as if the “_weight” (_300, _700, etc) suffix in the styling isn’t registering.

What’s super weird is I never uploaded the 400 weight version of the font :joy: I believe the only reason this typography shows up in the app is because it’s the default font weight for buttons (ie. I can’t actually manually set a weight of 400, buttons just default to it).

I must be doing something wrong.

Here’s the font uploaded in the font manager ( this is an edit, I recently uploaded the “normal” sized font):

Here’s the font configured for a title:
Screen Shot 2021-02-04 at 9.36.50 AM

Here’s the title with the wrong font in the built app (is this the default font?):
Screen Shot 2021-02-04 at 9.38.11 AM

Here’s a button in the built app with the right font:
Screen Shot 2021-02-04 at 9.38.46 AM

@Mevi I tried with the same font you used in your screenshots (indie flower) and it didn’t show up in the build

Hmm… There might be something odd going on here, but I did some additional tests with different font weights and didn’t have a problem, so I’m not sure what.

:confused: I’m not sure how to help you, or how to test this further. If you have an open-source free to use font you’d like to share with me and the steps you tried to get it to work but it didn’t, I can give it a go and see if I can find the issue.

@Mevi I must be doing something wrong. Do these steps look right?

Built App:

I believe I have a similar issue. I uploaded a custom font that shows up in the editor but not in the preview

https://forums.appgyver.com/t/custom-font-issues/4176/2

Editor:

image

Preview:

image

To me it seems like the font file is not rendering

Here is how to replicate the issue:

Font file: https://appgyver-meap-assets.s3.amazonaws.com/uploads/asset/acual_asset/d64bf466-81e3-4caa-a465-f004a406ff4f/font.ttf

Character used: 𐳻‍𐳾 (Please copy - paste this character. It will show up as a letter)

App editor: :
image

Preview:

image

HTML test with same font file and character:

UPDATE:

I figured the issue. Appgyver adds the font-weight at the end of the font name which causing the issue. I name my font Web_OldHungarian, however because my uploaded font is in 400, Appgyver adds _400 at the end of the font family name. Because of this, the font name that I define no longer matching. I need the app not to modify my font name so it will match the name I described when uploading the font

If I change the font family name in Chrome developer tools and add _400 at the end, it works, However I can not do that in the font name settings. So the issue is that the font family name gets modified with the font weight. Please fix this issue. Thank you @Mevi

1 Like

Also not sure if this is related to

https://appgyver.canny.io/bug-reports/p/custom-font-not-showing-in-preview-app

I added a new bug report for visibility: Custom Fonts not showing in web builds | Voters | AppGyver

@Tyler_Phelan

So I tested my app. I built a web version and the custom font is showing. So it seems like that it is not showing in the preview, however if you build your app the font will show up. At least is showed up for me. I used 2.4.35 Same way as explained here:

https://appgyver.canny.io/bug-reports/p/custom-font-not-showing-in-preview-app

App preview:

Built app:
image

@developer Oh! Then we must have different issues. Maybe it’s my font files, but I used presumably the same file @Mevi used? Could you please share a font file that you have gotten to work in the build? I’m more concerned with the build than the preview.

You can see it above

Font file: https://appgyver-meap-assets.s3.amazonaws.com/uploads/asset/acual_asset/d64bf466-81e3-4caa-a465-f004a406ff4f/font.ttf

Character example: 𐳻‍𐳾

This is a special font so you would need to copy and paste the character above

Also if you share your font file in DM with me, I’m happy to test it for you

@Tyler_Phelan Can you test again with 2.4.35? I tested the web build with it (since I had only tested mobile earlier and that worked)

@developer I reported the issue of renaming font files which caused you to have trouble, thanks for reporting!

1 Like

Thank you @Mevi I discovered what happens. So basically if the font that is uploaded is 400 ( Normal) the app does not modify the font family to xyzfont_400 which is required in order to see it in the preview. However for any other font weight, it works just fine. For example xyzfont_200.

1 Like

@Mevi I tried with 2.4.35 and still don’t see the fonts. Could you please share a font file that has worked for you? I’ve tried a bunch and haven’t gotten any to work in the builds.

I didn’t happen to have any of those so this is what I did:

  1. Went to Google Fonts and downloaded the font family Newsreader
  2. Uploaded Newsreader regular, semibold and light in Composer (not pt versions but full, named like Newsreader-Regular.ttf) Screenshot 2021-02-15 at 9.41.54
  3. Saved
  4. Used Newsreader font in texts (note: the ones with font weight 400 did not appear correctly in web preview, like @developer noted)
  5. Saved
  6. Queued a 2.4.35 web build from Build Service
  7. After waiting for the build to complete, opened the build from web url (like https://________.appgyverapp.com) (changes can take a bit longer to apply so make some other change as well like adding an icon or whatever so you can be sure changes went through)

Screenshot 2021-02-15 at 11.54.54