Formula NOW("YYYY-MM-DD") has bug in it

NOW(“YYYY-MM-DD”) is not giving the current date but it is giving 1970-01-01 in the date pick flow function.

Details: If you use pick date flow function and put the formula NOW(“YYYY-MM-DD”) into the maximum date and your minimum date is for example 1980-01-01. I simply won’t work. AppGyver application will crash and automatically be closed

Hi, I tried to repro this issue myself. It seems that it’s caused by having maximum date NOW("YYYY-DD-MM") instead of NOW("YYYY-MM-DD"). So if you just change the order of months and days the issue should be fixed.

@Tomi_Laakso Thanks for your reply. I tried your suggestion but it is not changing anything. Behavior is still the same. if you put minimum date like 1990-01-01 and maximum date like NOW(“YYYY-DD-MM”) or NOW(“YYYY-MM-DD”), the app will simply crash anyway

Umm… That’s odd. I’m not able to repro the issue then. Could you answer a couple of questions:

  • Are you using Android or iOS?
  • Which phone are you using?
  • What’s your phone’s operating system version? (Android 10, iOS 13.6. etc.)
  • What’s the AppGyver app’s runtime version you are using? (You can find it by opening the AppGyver app and pressing your username on top before opening your own app)

Also, if it’s okay to take a look at your app Could you tell me your app’s ID? (You can find it in the app URL between applications/ and pages/ )

@Tomi_Laakso Thank you for your kind response. Magically it just started working. I don’t know why and how. But the issue has been now solved. I would really appreciate if you would please help me with this issue. Please help me, no one is responding on that issue. Thank a lot man