Frequent errors building an Android app

Hello. I have successfully created an Android app according to my needs but, unfortunately, I am not having success in building it. I have already tried several times but it always gets wrong. I do not have any programming experience or background and so the Error Log File is not that helpful to me.

I do not consider my app to be very sophisticated in resources and neither layout, so I do not understand what is wrong. I would be glad if you could provide me with some help to sort things out.

Build ID: 353591
Runtime Version: 3.3.5
File Type: AAB

By the way, this Runtime Version is the only one available to me. If I try to select other versions (e.g., 3.4.5; 3.4.4 or 3.2.15) it prompts an error message saying that I should choose APK file instead. However, the button does not become active to be selected. So, I am forced to choose AAB/3.3.5

Thank you very much in advance for your attention.

Hi! Please try again with 3.4.10. There are some build issues that were fixed for it, hopefully that helps :). There are also some further issues that we are fixing for 4.3.X I believe, so if 3.4.10 does not fix them, please wait for the next release.

Hello Mevi. Thank you very much for your message. I had decided to leave my project on standby for a couple of months to see if the new updates could contribute to fixing the issues I experienced but, unfortunately, I still do not manage to have my app built. I have created a new keystore JKS and tried to build my Android app using both APK and AAB (versions 4.1.6; 4.2.12; and 4.3.6 to both options) but nothing changed and the app simply is not built. I do not what else I can/should do, since, as I said before, I have no programming backgound.

What is the error log you are getting? Perhaps I can help you understand it, if there’s something that can be acted on.