Full screen not displaying properly

Hi there, i have followed the tutorial very diligently i think on making a full screen background and for some reason I have a big space at the bottom of the screen above the bottom nav bar. I double checked my settings and all appear to be right.

1 Like

Hi Ted,

Did You fix this or still its there? If it’s fixed, please let me know how to do.

I have the same problem:

If I change the height formula to “window.height” instead of viewport.height I can avoid the white space, but in either case whenever the keyboard shows I cannot scroll until the end of the screen. This is as far as the screen goes:

Any ideas from the experts here?

Thanks and best regards,

Joerg.

I “kind of” solved this. But it would be nice if the official instructions actually included all the caveats and details. I’m specifically referring to this post: Full-screen background - Composer (appgyver.com)

Here are the changes I did:

  • Disable “Stretch to viewport” and “Disable scrolling” on the page
  • Set the main container height to systemVars.dimensions.window.height (instead of viewport height).
  • Do not set any height on the Scroll view

I’m not sure if this is the best solution, or even if it works for all use cases, but it did solve my particular issue.

Best regards,

Joerg.

1 Like