GIFs don't work with the Image component

we are building an app where we use lots of gifs and we are having some trouble displaying them.

First, we uploaded the gifs as image assets to AppGyver and used them with the Image component. Back then everything worked just fine. Then, all of a sudden, the gifs stopped working completely in the build for iOS, there was just blank screen where the gif was suppose to be. In the SAP test app everything still worked but not in the built app for iOS, for Android everything still worked.

To fix this issue, we moved our gifs from AppGyver to Xano. Again, all went well for a few days but then the gifs stopped playing on Android, only the first frame would show as a still image. This was for both the SAP test app and the built app on Android. And for iOS both the SAP and build still work.

What could be causing these problems? We haven’t changed anything on how we do things apart from moving the gifs to Xano. But we have always used the Image component and a link to display our gif. Is there anyone with similar problems? We also use images on our app that are stored as image assets in AppGyver and displayed with the Image component, there has never been an issue with those on any version.

Here is an example of a gif stored in Xano:

Here is an example of a gif stored in AppGyver:


I never had the problem but maybe it should be loaded on the storage of the user. Like that, you are sure it works. Otherwise, transform the GIF into a lotie.