Google Playstore Target API level requirements

I get the following error when I publish on Google Play Store. How do I resolve it? Thanks

"Target API level requirements from August 2020

Warning:

Your app currently targets API level 28 and must target at least API level 29 to ensure it is built on the latest APIs optimized for security and performance."

Oh! This is actually something that we have to fix on our side. Thanks for reporting! If you’re still able to publish for now with this error, you can go ahead, but we will publish a new version of our runtime which includes the API level bump!

This is actually already fixed with client runtime version 1.9.15 – can you try rebuilding with that client version?

@Mevi

Thanks for the responses… I rebuilt with 1.9.15 and that specific warning is now gone but I do get the following warnings (See screenshot). I’ll paste them here for anyone searching the same.

Warning

This APK results in unused code and resources being sent to users. Your app could be smaller if you used the Android App Bundle. By not optimizing your app for device configurations, your app is larger to download and install on users’ devices than it needs to be. Larger apps see lower install success rates and take up storage on users’ devices.

Warning

This APK contains Java/Kotlin code, which might be obfuscated. We recommend you upload a deobfuscation file to make your crashes and ANRs easier to analyze and debug.

Warning

This APK contains native code, and you’ve not uploaded debug symbols. We recommend you upload a symbol file to make your crashes and ANRs easier to analyze and debug.

These are just Google advertising their managed App Bundle which we can’t provide since it defers APK generation and signing to Google Play and also tips to improve debugging your app through Play Store portal, which we are not providing at the moment.

i.e. this will not majorly affect your app in any way.

Great… I was able to submit the app without a problem. Thanks