Google sample chart is not displaying

Google sample chart not displaying in preview

It shows when run in my smartPhone.

Yeah, the charts component is currently mobile-only. We hope to get a sprint done soon where we expand many of the mobile-only components to work on web too.

Is there a way to zoom in on the chart automatically? It’s very small with a lot of white space inside the chart view component.

I’ve tried adjusting the view component using the style tab and also tried defining chartArea in the custom JavaScript component.

Neither seem to be working correctly.

@William_Glass

Hi there!

It seems Google Charts has an config option for a “maximized” theme.

options: {
  theme: 'maximized'
}

Hope this helps!

1 Like

It worked great! Thank you!

Hi Harri. Do you have any updates on when the charts component is expected to expand to work for web apps?

We’re in the final stabilization stretches of the new runtime; then our plan is to get the third-party plugin infra stabilized internally so we can make plugin upgrades on a more sound architecture – so hopefully just a couple of weeks more, but we can’t unfortunately commit to a schedule just yet.

1 Like

Hi, I just started learning Appgyver. How do I set the theme for the sample chart?