GPS position Android not giving latest value

Hi there, when using the device gps location call on Android, it always gives an old location(nowhere near the actual GPS position, about 10 km further).

You can see the actual GPS beeing activated on the phone, but the latestvalue just isnt updated.

PS I also tried the poller, but that is not working at all. Tested this on a oneplus and xiaomi phone, both the same problem.

Is anyone else experiencing problems with GPS location on Android? This seems to work fine on iOS.




Screenshot 2021-10-04 at 16.23.19
Screenshot 2021-10-04 at 16.23.14

Anyone? Seems to be a rather critical bug?

Hi! There’s a known problem that the latestValue updating only works on the accuracy of 100m here. However I tested just now and was able to get an accurate location from sensorVars.geolocation.latestValue up to 25m or so – please check that out. Other than that, please check that the device shows an accurate location in other apps as well.

The positions on the map are about 5 km apart, so that can’t be it. The problem is only on Android. Where did you test? Previously (2 months ago) we didn’t seem to have this issue on Android specifically.

It seems to get an historical value instead of the latest position on Android only. When the flow is triggered on Android, you see the GPS activating, but the position is nonetheless an historical one.

Also, the reset geolocation flow isn’t changing this.

@Mevi please check if this is also the case with your testing if possible. GPS is crucial for our app: Creator of the Week: Smart farming sensors & higher growth at Farm21 | by Esmeé Xavier | Aug, 2021 | AppGyver

Somehow this fixed itself

Sorry to get back to this again, it isnt working yet. On Android it keeps showing old historic locations instead of a new location gathered with GPS.

Hmm. I believe you that there’s a specific issue on Android – can you please post a bug report on our tracker with a precise explanation of what is going wrong and on which version of preview (and which device(s)).

Is this still an issue?

You having problems too Phil?

I found a workaround.

On webapp you have to use a different flow function, on android you can´t write the sensor values to variables. It all adds to the fun. It would be too easy if it just worked :slight_smile: