How to make app load faster?

Good day, my app loads data via rest api(xano) from the backend. Is there a way I can get things to load faster by only loading the things that will appear first. (like YouTube loading videos at the top then loading more as it scrolls) I noticed that all the data loads at once and that makes things very slow. Also is there a way to stop the image border from loading before the image, because at first it appears as just an empty border. Any help would be appreciated. Thanks I’m advance

Hi, if you are using a regular scroll view I would recommend switching to Recycler view from the marketplace in the repeated listing to improve performance.

1 Like

Thank you for the reply, when I use this everything I place inside it isn’t displayed in the Preview app. I’m using the SAP Appgyver Preview on IOS. Not even a button with no logic is displayed. What should I do?

Hi, there’s a known bug at the moment that if you use Stretch to viewport height setting on your page, the Recycler is not visible, could this be the issue?

Thank you, it only appeared when I stopped using stretch to viewport height and disable scrolling. I’ve made a custom header, and I don’t want it to be scrollable. I only want the items in the recycler view to be scrollable. Is there a way this can be done?

are there minimum hardware requirements for devices in order to load the application fast?

Hi @Donnico_Miller, you can use absolute positioning on the header to make it “sticky”:

@Jessica_Bullet it’s difficult to give any exact requirements, most reasonably recent smartphones should be able to handle the apps. More often than not, slowness comes from poor internet connectivity or ineffective execution (too many things being loaded or rendered in the app at once), not the device you’re using.

1 Like

Thank you very much but when I do that it Becomes invisible and the other components overlap it, as it I turned visibility off. It also moves to the left of the screen

It’s like that in the previewed as well

Hi @Donnico_Miller, try increasing its Z-index so that it positions on top of other content, and set it to 100% width to fill the screen horizontally. :slight_smile:

Thank you very much, and thanks for being so patient, this worked to make it visible and occupy the full width, however, it still scrolls with everything else, although it is set to absolute as if that changed nothing

Hi @Donnico_Miller, I found out a workaround for this layout:

  1. Page settings:

    "

  2. Custom header can be set with position: relative

  3. For the recycler view, give it an exact height, you can use the systemVars to accommodate different screen sizes:

Thank you very much, that worked