How to make the multiline input field show more than 1 line during input❓

image

This input field has 4 lines of text. How can I either define the number of lines to display during input or make it auto stretch?

@Vili Sorry to bother you, this is probably a quick fix but a critical one for UX: no one can write a full paragraph within that one line field.
Shall I report in the tracker (as a bug: size should be adjusted) or is there a fix possible by editing the component?

Hi,

The auto stretch feature of the multiline inputs works currently on mobile only - what device are you using? To have multiline inputs on browser, I recommend looking into the input primitive (not the input field), and setting its height manually.

1 Like

Thanks.
That side of the “app” is actually a web admin so will be used in browser.
Will switch to primitive, hoping I can replicate the same look and feel (no borders…).

You can also edit the size of the primitive input that’s inside the input field component if you want the same look.

That’s what I originally tried to do but could not find where to change the field size.

Open the template editor and change the size of the “Text input” component in the layout tab.