HTTP Request on Push Notifications

Hello, I’m new on AppGyver and I found the push-notification tutorial very poor of details, lack of details…

for example, how i fill this parameters ? where to look on firebase?

11

Any information will be welcome
Thanks

Hi,

You’d need to check the API documentation for push notifications in Firebase. There you should find the URL, what method to use, what headers to include, and what to send in the request body.

This Tutorial I did might help you.

1 Like

Hi,
I did it as Push Notification Tutorial but I´m getting an error 401 or 403 when I try to run the http request.

That´s how I did the configuration
http configuration 1

The Key that I´m using is the Server Key (Cloud Messaging)

II’ve been trying for 3 days with several keys and I just get an error. I tried with API and services credentials and only the error.

Does anyone know what can it be?

Your POST URL should be this: https://fcm.googleapis.com/fcm/send

And your Request Body should be the JSON object of the payload data.

Ok, but first I have to run the http post to add the Device Token to the Firebase as shown in the picture below or Is it not necessary to make this insertion?
Capture1

Ok I see you are Subscribing (Creating) a topic … But you only need to do that once per Device Token.

Can you output the raw Error message in an Alert box and see what it says?

It´s returning just the code. The raw Error or even message error is empty.

But the strange thing is that it returns this code on port 2. In the documentation it says that this port has been discontinued.
error port 2

I’ll test the push because it may not be an error.

Try generating a new Server Key in Firebase. I had to do that once before before I could get it to work.

I tested it by sending a message through the firebase console (https://console.firebase.google.com/) and it worked. But when I try to send by https://fcm.googleapis.com/fcm/send I got an error

{
“multicast_id”: 5811705542714809000,
“success”: 0,
“failure”: 1,
“canonical_ids”: 0,
“results”: [
{
“error”: “MismatchSenderId”
}
]
}

I´ll try to generate a new server key

I generated a new key and the error still happened. I’m thinking that maybe in the past I registered the device token using one key and I must have deleted it and now when I send the message through the integration it doesn’t works because the key was different. I will delete the devices registered in the base or test with a new one and see if it works

Good day, did you find the solution? I’m having the same problem

Hi Donnico,

I didn’t find a solution and gave up.
If you discover something please let me know.

I figured out the problem I had. It was 2 problems.

  1. The “get firebase token” flow function should be used instead of the “get device token.” I believe the “get device token” and “get firebase token” works the same on android but it definitely gives a different token on iOS. To be safe I used “get firebase token” for both the iOS and android version.

  2. When testing I was using the token I got from the Appgyver Preview app. Only the token that comes from the built app works.

Hopefully this works for you, or anyone who has the same problem.

1 Like

YOUTUBE VIDEO FOR PUSH NOTIFICATION

PUSH NOTIFICATIONS ON IOS IN APPGYVER FROM FIREBASE
LINK - Push notifications in Firebase on Appgyver IOS | appgyver tutorial | push notifications on IOS - YouTube

PUSH NOTIFICATIONS ON ANDROID IN APPGYVER FROM FIREBASE
LINK - How to Push notifications in Firebase on Appgyver Android | appgyver tutorial | push notification - YouTube