I send REST API request, the response is ok, but nothing in the body field

I have this problem, after I have created a direct connection through REST API using POST method I expect to get a response in the body that comes as a url link. But nothing comes through. After sending a request the status is green and says that everything is ok. But the response body is empty. I tried to specify the response parameters manually in the scheme, but when tested it resets them and nothing comes. However, if you go into the developer tool in Chrome Browser, you can see that the abandonment is processed and the response comes, but for some reason does not come to AppGyver. I tried to process data with Postman, it works correctly and the answer comes in the body with the url. Please help me to understand what can be done to solve my problem. Thank you.



1 Like

Hey!

I think the issue might be that the response is just a text instead of a JSON object and is therefore not displayed in the data resource test. I think you can still access the url in your app with something like outputs["Create Record"].response, you can test it out that way. Or if you have control over the backend and its responses, make sure that it returns a json object like {url: the_url_here}

1 Like

Thank you very much for your response. I tried several different options, the first one I did was Create Record. The first one I did was Create Record and linked to Toast to understand what data is coming out. Checked no data. Screenshot attached. Second way i tried binding via JS and put inputValue as result of Create Record. response, then prescribed JS to take data and process it with JSON.stringify. I also tried reverse JSON.parse and it gives me null at the output and don’t see the data… But at the same time, I see in the developer tool that the response with data (url) I try to set in the scheme when configuring REST API response custom and prescribe it waiting for data (url) but it resets and doesn’t get data… What can be done in this situation, would be happy to get your help. thanks!

2022-02-28_13h18_24
2022-02-28_13h21_15
2022-02-28_13h22_01
2022-02-28_13h22_24
2022-02-28_13h22_58
2022-02-28_13h36_03

Hey,

I can’t really see the screenshots, they’re really small. Can you provide larger screenshots? I’m wondering why the toast doesn’t show any response data if the network shows that the url is coming through, so I’d like to see the toast setup :slight_smile: and what exactly is resetting?

1 Like

Yes of course, here’s a bigger screenshot, I hope you’ll see better.

Thanks! Looks good, so maybe the url is not found in outputs["Create Record"].response, are you able to bind the following formula to the toast: ENCODE_JSON(outputs["Create Record"]) ? Let’s see if something comes of that :grin:

1 Like

Yes.Sure.
Thank you very much for your help, I tried it this way and it gives me an empty object. I don’t even know what to do. If you have any options, I would appreciate it. Thank you for your help.


Hi Aleksey,
I have the same issue, do you have to fix it ?

@simplyapp4u what does your setup look like? Do you get some success response and not an error?