Incorrect certificate error. Using new Apple WWDR

Info here: WWDR Intermediate Certificate Expiration - Support - Apple Developer

My ios builds keep failing with this error. I wonder if it has anything to do with the recent Apple certificate changes. See link above. The iOS Distribution Certificate is on the impacted list.

I have NOT been able to perform a successful build yet in the past 3 days!!

Version: 2.4.28
Status: error
Message: Detected incorrect certificate, should be a distribution certificate! Cert was: 0 valid identities found

Excerpt from WWDR Intermediate Certificate Expiration - Support - Apple Developer

This requirement also impacts all software signing certificates generated after January 28, 2021, by developers with Personal accounts in Xcode, as well as members of the Apple Developer Program, Apple Developer Enterprise Program, and iOS University Developer Program.

I’m wondering if the AppGyver builder using the updated certificates?

https://developer.apple.com/certificationauthority/AppleWWDRCA.cer
https://www.apple.com/certificateauthority/AppleWWDRCAG3.cer

This was fixed here, I believe!