Input primitive ignoring choice of keyboard type

I am using an Input Primitive for inputting a number, but even though I selected Keyboard Type as “Number pad”, when editing this value it would always bring up the full keyboard.

After pulling my hair out for a while, I found the problem. The Auto-Capitalize was set to “Sentences”. This seems to force the full keyboard, even though this control was bound to a number variable and I had selected the Number Pad keyboard type. Not sure this if I’d call this a bug (since auto-cap doesn’t really make sense for numbers). But I would think keyboard choice should be obeyed and the capitalization choice should just be ignored for a numeric input.

The way I got into this mess was from cloning a text input control and modifying it for a number field. Cost me more time than it saved me.

Hey @Marty_Flickinger, which platform did you encounter this bug on? I couldn’t get it to reproduce at least on iOS, any choice of auto-capitalize with “number-pad” seems to bring up the number keyboard.

Observed this on Android. I created a test app just now to test this more thoroughly. Here’s what I learned:

  • This problem occurs on Android phone, but not iOS phone or tablet
  • Setting the Auto-capitalize to any setting except none (sentences, words, characters) will cause the default keyboard to be used, regardless of the setting selected for Keyboard Type
  • This will overshadow all other keyboard types: email-address, number-pad, decimal-pad, phone-pad
  • Occurs equally on Input Field or Input Primitive
  • Occurs using Appgyver Preview (runtime 2.12.6) and SAP Appgyver Preview (runtime 3.1.5)
2 Likes

Good catch. I remember someone here ran into that same problem a long time ago and nobody could ever figure it out.

Thanks for the details @Marty_Flickinger , I’ll put the bug report forward!