iOS build error (again and again) with certificate


I’m frequently facing this error when building my project for iOS:

error: No signing certificate “iOS Distribution” found: No “iOS Distribution” signing certificate matching team ID “XXXXXX” with a private key was found. (in target ‘RNVApp’ from project ‘RNVApp’)

I have to go through all the certificate process again in order to fix it. Then a couple of days later when I try to build again, same error.

Is it a known issue or bug?

Please make sure that the “bundle id” is correct. This might cause it.

This really has to match the one that you have in your Apple Developer Profile. Else it will fail.
Also make sure that you generate your ios certificate with the same bundle id, else it also might fail. The easiest way to make sure that you have the correct bundle id is to use only one. And delete or remove all those that are not in use.

This should not be a bug, but rather a misconfiguration. At least hopefully. I’ll be making new IOS builds in the upcoming days, so if I face the same issue, I’ll let you know.

The thing is that it works immediately after I configure these things. Then after a couple of days I start getting this error again without any change with those settings.

I’ll redo everything again for the 5th time. Let’s see.

Thanks for your inputs.

Then before the build generation try refreshing the page of the build service, just always validate those files. Sometimes maybe it is a caching issue, a previous bundle id is saved in the configuration. So just check that, check what you have in your certificate, and change it there. It is less work than generating the certificate again.

Refreshing the build service page didn’t work, but this time I simply upload once again the .p12 .mobileprovision files and it worked. Still weird but at least I don’t have to generate the files every time.

Thanks @Mihaly_Toth