IOS build failed every-time

I have generated a p12 certificate and then a provisioning profile. Everythings looks good but when I build it fails with this error. Please help

status: error
Message: Codesign Error: ‘0 valid identities found’. You might have generated a new certificate in the Apple Developer Center, but you have not generated a new provisioning profile which matches the new certificate. Please generate and upload a new provisioning profile, then request a new build.

Is there anyone who can look into this, please? this is urgent

Hi,

Are you sure the provisioning profile matches with the certificate you set in the app build assets? Did you already try doing as the error suggest:

Please generate and upload a new provisioning profile, then request a new build

Thanks for your reply. Yes, I have tried it as well, nothing changed. Every time it fails. To be sure there is only one certificate in my developer account and then I am using that certificate to generate the provisioning profile.

I see! Can I get your app id so we can check it out? The id is the number sequence in your app url :slight_smile:

for sure, my app id is 196163

I checked with our dev team, and apparently that error message is most of the time accurate, so I’m guessing there’s still some issue with the certificate and profile. I would check everything again, keeping in mind that the app identifiers bundle id has to match the bundle id given in build service (can be checked from identifiers in developer.apple), and the provisioning profile has to be created after the profile and certificate. If all else fails, try starting over with generating a new certificate, profile, etc…

Here’s our documentation about the subject, if you haven’t checked it out yet.

thanks for your response. I have checked everything again and again, There does not seem to be any problem with certificate and provisioning profile. Also I took care of identifiers as well. I have posted it here after several tries

Alright, if you’re sure about it then I would maybe start the process from scratch, creating new certificates and profiles etc. After all that error doesn’t come randomly and is not dependent on Composer, so maybe a tiny detail at some point of the build process went wrong :confused:

Ok, I will try again and let you know. :expressionless:

1 Like

@Cecilia I have generated a new provisioning profile and requested a new build but it is taking forever now. It has been more than 4 hours the build is still in queue. Please help. Thanks

Please help me. It is urgent

it has been more than two days the build is still in queue. please help

Please upvote my bug report to bring it to their attention App builds queueing indefinitely. | Voters | AppGyver

1 Like

I will do it now. thanks a lot

Hey! Build service is working now, here’s a thread with more info

@Cecilia my builds are still in the queue. How long it could take more to give me some results?

The notice says that we cannot know how long the builds will take.

okay thanks, Is it possible that after a long time my build would fail due to an error in the build configuration or something like that, or is that check has already been passed by the build?

@Cecilia my build just got failed with the same error
Codesign Error: ‘0 valid identities found. You might have generated a new certificate in the Apple Developer Center, but you have not generated a new provisioning profile which matches the new certificate. Please generate and upload a new provisioning profile, then request a new build.

I have rechecked everything and everything seems to be fine. Please help me with this. Thanks