iOS Build Failure - The engine "node" is incompatible with this module - YARN

I am having trouble getting my iOS build to succeed. It keeps failing. I was able to solve a few errors, but am left with this, and cannot figure out what to do next. Any ideas? Is this an issue in my app or the build service?

App ID: 597676

Runtime version: 4.9.118;
AB version: 1.7.11
COMMAND:

/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/rnv/bin/index.jsconfigure -p ios -s standalone_appstore -c standalone --ci --yes --skipRnvCheck --packageManager yarn --template @appgyver/orchestra-template-standalone@4.9.118 --hooks --npxMode

FAILED with ERROR:

FAILED with ERROR:
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
info Visit yarn install | Yarn for documentation about this command.
Command failed with exit code 1: yarn
warning package.json: No license field
warning No license field
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.15”
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
yarn install v1.22.19
[1/4] Resolving packages…
[2/4] Fetching packages…
info Visit yarn install | Yarn for documentation about this command.
warning package.json: No license field
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
Error: Command failed with exit code 1: yarn
warning package.json: No license field
warning No license field
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.15”
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.5”
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.5”
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
yarn install v1.22.19
[1/4] Resolving packages…
[2/4] Fetching packages…
info Visit yarn install | Yarn for documentation about this command.
at makeError (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/lib/error.js:60:11)
at handlePromise (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/index.js:118:26)
at processTicksAndRejections (node:internal/process/task_queues:96:5)
Seems like your node_modules is corrupted by other libs. ReNative will try to fix it for you
[ task ] cleanNodeModules[1]
[ task ] installPackageDependencies[2] packageManager:(yarn)
[ error ] COMMAND:
yarn
FAILED with ERROR:
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
info Visit yarn install | Yarn for documentation about this command.
Command failed with exit code 1: yarn
warning package.json: No license field
warning No license field
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.15”
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
yarn install v1.22.19
[1/4] Resolving packages…
[2/4] Fetching packages…
info Visit yarn install | Yarn for documentation about this command.
warning package.json: No license field
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
Error: Command failed with exit code 1: yarn
warning package.json: No license field
warning No license field
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.15”
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.5”
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.5”
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
yarn install v1.22.19
[1/4] Resolving packages…
[2/4] Fetching packages…
info Visit yarn install | Yarn for documentation about this command.
at makeError (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/lib/error.js:60:11)
at handlePromise (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/index.js:118:26)
at runMicrotasks ()
at processTicksAndRejections (node:internal/process/task_queues:96:5)
[ error ] COMMAND:
yarn
FAILED with ERROR:
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
info Visit yarn install | Yarn for documentation about this command.
Command failed with exit code 1: yarn
warning package.json: No license field
warning No license field
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.15”
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
yarn install v1.22.19
[1/4] Resolving packages…
[2/4] Fetching packages…
info Visit yarn install | Yarn for documentation about this command.
warning package.json: No license field
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
Error: Command failed with exit code 1: yarn
warning package.json: No license field
warning No license field
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.15”
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.5”
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.5”
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
yarn install v1.22.19
[1/4] Resolving packages…
[2/4] Fetching packages…
info Visit yarn install | Yarn for documentation about this command.
at makeError (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/lib/error.js:60:11)
at handlePromise (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/index.js:118:26)
at runMicrotasks ()
at processTicksAndRejections (node:internal/process/task_queues:96:5)
┌──────────────────────────────────────────────────────────────────────────────┐
:rocket: SUMMARY | 12/21/2023, 10:00:52 PM │
FAILED with ERROR:
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
info Visit yarn install | Yarn for documentation about this command.
Command failed with exit code 1: yarn
warning package.json: No license field
warning No license field
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.15”
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
yarn install v1.22.19
[1/4] Resolving packages…
[2/4] Fetching packages…
info Visit yarn install | Yarn for documentation about this command.
warning package.json: No license field
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
Error: Command failed with exit code 1: yarn
warning package.json: No license field
warning No license field
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.15”
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.5”
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.5”
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
yarn install v1.22.19
[1/4] Resolving packages…
[2/4] Fetching packages…
info Visit yarn install | Yarn for documentation about this command.
at makeError (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/lib/error.js:60:11)
at handlePromise (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/index.js:118:26)
at processTicksAndRejections (node:internal/process/task_queues:96:5)
Seems like your node_modules is corrupted by other libs. ReNative will try to fix it for you
│ [ error ] COMMAND:
yarn
FAILED with ERROR:
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
info Visit yarn install | Yarn for documentation about this command.
Command failed with exit code 1: yarn
warning package.json: No license field
warning No license field
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.15”
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
yarn install v1.22.19
[1/4] Resolving packages…
[2/4] Fetching packages…
info Visit yarn install | Yarn for documentation about this command.
warning package.json: No license field
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
Error: Command failed with exit code 1: yarn
warning package.json: No license field
warning No license field
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.15”
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.5”
warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.22.5”
error react-native@0.73.1: The engine “node” is incompatible with this module. Expected version “>=18”. Got “16.20.0”
error Found incompatible module.
yarn install v1.22.19
[1/4] Resolving packages…
[2/4] Fetching packages…
info Visit yarn install | Yarn for documentation about this command.
at makeError (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/lib/error.js:60:11)
at handlePromise (/usr/local/lib/node_modules/@appgyver/orchestra-builder/node_modules/execa/index.js:118:26)
at runMicrotasks ()
at processTicksAndRejections (node:internal/process/task_queues:96:5)
│ │
└──────────────────────────────────────────────────────────────────────────────┘

I have the same problem
What version of Mac OS you use for the certification?
FAILED with ERROR:

Command failed with exit code 1: /Users/admin/.nvm/versions/node/v16.19.1/lib/node_modules/@appgyver/orchestra-builder/node_modules/rnv/bin/index.js configure -p ios -s standalone_appstore -c standalone --ci --yes --skipRnvCheck --packageManager yarn --template @appgyver/orchestra-template-standalone@4.9.124 --hooks --npxMode