Ios certificate

Hi
i have downloaded my cerificate and profile file from ios developer site
then uploaded to configuration page but, what password i should insert ???

image

When i build my app, i receive alwais problem with ios certificate but i think is not a cetificate problem

When you created the certificate it prompts you for a password. You need to put a on it password and also add it to the buildservice.

Strange when i build the ios distribution certificate from developer site of apple I don’t remember the site ask me a password……

I tried to insert my usual password but doesn’t works

image001.jpg

Maybe take a look at this I found by quick googling?

Very interesting

Thanks i’ll try

Hi

I followed this tutorial and generate my certificate.p12 but the error is always the same : Detected incorrect certificate, should be a distribution certificate! Cert was: 0 valid identities found

I’m a little bit frustrating :frowning:

Are you sure you’re using a Appstore distribution certificate? I know the Apple’s system is quite complicated and frustrating. Hopefully we can make it more managed by AppGyver at some point.

Anyway wouldn’t hold my breath for iOS builds right now since they can’t be released. New iOS builds to require a different launch image structure for successful App Store submission

Hoping to get a fix live tomorrow and other new features for build service next week.

1 Like

Great

I hope this fix my problems :wink:

image001.jpg

Hi @corrado_ravinetto & @Sasu_Makinen!

Was anyone able to find a solution to this issue? I am having it now. There wasn’t any point in the certificate creation process that it asked for a password. When it asked for a password for the .p12 file, we left it blank. I’ve tried building with both the certificate and the .p12 file (password field left blank), and it is giving me this error:

Hoping someone already knows how to navigate this :slight_smile:

Hi @erin_wagner

I fixed this problem following this guide : https://calvium.com/how-to-make-a-p12-file/?cn-reloaded=1

Try and telo me.

Bye

@corrado_ravinetto Thank you so much for that guide!

We’re still not having success, but since I know it worked for you, that makes me think that I have an issue elsewhere in my configuration. (Next, I’ll be looking at whether I did the provisioning file correctly.) You helped us big time by providing that link. Thank you!

note that you want appstore distribution.

I’m having this problem as well. I followed the guide above (https://calvium.com/how-to-make-a-p12-file/?cn-reloaded=1) step-by-step, and still get the same error. Can I get some help?

Hi! Sorry it took a while to answer. If I understand correctly and you’re getting the error about the certificate not being distribution certificate, create the certificate again to be iOS AppStore Distribution type (not general AppStore, but specifically for iOS). :thinking:

I got this sorted, thanks. It’d be super helpful if the interface had some documentation about what to enter in the fields and file uploads. For instance, the “certificate” field doesn’t want the “.cer” file, but it wants a .p12 file, which, to those of us new to building apps, might be confusing. Thanks!

1 Like

Hi, I get the error when trying to build the app for iOS:
Status: error
Message: Detected incorrect certificate, should be a distribution certificate! Cert was: 0 valid identities found

A month ago I did a test with another app and following the tutorial How to make a p12 file for iOS: 2020 Update - Calvium
I was able to create the app successfully in version 2.4.26

Now I have repeated all the steps like 100 times and I always get the same result in appgyver:
Status: error
Message: Detected incorrect certificate, should be a distribution certificate! Cert was: 0 valid identities found

Notes:

  • I use macOS Catalina 10.15.7 with Xcode 12.4 installed.
  • In Keychain the installed certificate of iPhone Distribution say “This certificate is Valid”
    -To download it I select the Certificate and the private key to create the .p12 and set the same password that I have put in iOS Distribution Certificate password in appgyver.

I don’t know what to do anymore, I have sent an email to contact @ appgyver with more details for more help.

Hi! Sorry for the delayed answer, I heard you got a reply in the email although it hasn’t been resolved yet. Unfortunately the certificate problems are quite tricky as apple is a pain about the specifics. Hopefully this’ll get resolved for you soon.

Thanks for the answer, unfortunately I have not been able to solve anything. Apple tells me that the generated certificate is correct and the method of exporting the certificate and the private key as well. I would like the Appgyver buider to show more information when an error occurs because the “Detected incorrect certificate, should be a distribution certificate! Cert was: 0 valid identities found” is very generic. I have already generated more than 20 certificates on two different Macs, with different macOS and it always says the same. I remind you that I have already done the same procedure in December and YES it has worked correctly in Appgyver to generate my old app.
It has been several months paddling with some appgyver bugs but with great confidence and when I consider that I have finished the app I cannot generate it correctly. It’s really maddening, I knew that apple is more complicated than android but this is a real nuisance.

I am having the same problem and error. I have only tried it today in AppGyver a couple of times, but have successfully created certificates and built iOS apps before. I can’t see that I’m doing anything different this time as far as generating the certificate goes.