Ipad running ios 9.3.5 not compatible

How to get Appgyver preview on an ipad running ios 9.3.5?

When I try to download from the app store it says not compatible.