Is there a way to disable the five-second delay on click events?

There seems to be a five-second delay on all click events. This gives a bad experience for anyone. Is there a way to disable this nonsense?

I haven’t seen the 5-second delay anywhere. But it’s true responsiveness is overall bad with large lists. Can you further detail what you mention, @Daniel_Perley1 ?

Hello, most of the composite widgets that can be used with data adapters expose a property to disable the refresh an underlying data set. From what I have seen that’s a default setting. (You can as well set the data set refresh polling period to your own value as well.)

If you create your own data adapter binding logic you need to either remove the 5 seconds polling loop (that’s one click, one-off) and/or implement your own data set refresh logic.

The event-driven data refresh is the best approach as your data sets would be refreshed on demand only

I hope that helps;

PS. You may refer to a solution described here

Oh, THAT data refresh looping delay. I couldn’t tell that was the issue of OP. Is it, really, @Daniel_Perley1 ?

That default loop for data refresh is usually noticed on day one. I thought OP was an old timer around here and that he was refering to something else that only “seemed” like a five-second delay on “all click events”.

No, I am referring to the very noticeable delay on every click event whatsoever. There is a way to disable it in every bridge-based framework. Will figure it out soon.