Issue converting image to base64

Hi there,

I’ve been struggling while trying to upload device images to my application using ‘Pick Files’ > Convert file to base64 > HTTP request.
I’ve decided to post image of my logic:

When the user clicks a button, it goes to Pick Files node, just images to easily select all images needed to upload. The images list is saved to a page variable. The user can also take a photo using device’s camera. Image path is saved to the same list(array) as follows:

Now, when the user is ready, press the upload button, that triggers the following logic:

Now the problem comes when the nove Convert Files to Base64 tries to convert the image with src
content:///
returning the following error:

There is no error when converting files that was taken with device camera, and it uploads normally to my web app. Just the images coming from ‘Pick Files’ node that has this different path and thus can not be used to convert.

Any suggestions?

Can you check with the new 2.4.16 runtime? We should have fixed the flows to always return file:// format there – if the issue persists, we’ll get it fixed! What device and Android OS version is this happening on?

Hi @Harri_Sarsa,
Thank you for your support.

EDIT: Worked! Despite the Pick Files returning content, ‘Convert to Base64’ worked as expected and the upload went well. Thank you guys!

I’ve updated all nodes to the latest versions and re-run again the application but it still returns content:/// on ‘Pick Files’ node.

I’ve also deleted the previous ‘Pick Files’ node and replaced with a new one (just in case) and it didn’t worked.

AppGyver App on both android phones says runtime version 1.9.22, and I can’t upgrade, 'cuz there is no update.

My android devices are a Galaxy S8+, running android v9 from June 1st, 2019 (latest available for this device, at least on Japan from my carrier locked) and also on a Redmi Note 7, running Android 10 (QKQ1.190910.002)

If you check the post at Open beta test for the new runtime! there’s instructions to get v2.4.16 running on your device – let me know how that works for you!

I am also having this issue. “Pick files” returns:
image
This is on v2.4.21.
I have also tried to manually change “content” to “file”, without sucess.

Thanks, we’ll investigate!

Hi again guys,

I’m raising this thread as this problem is happening again. This time I’m using ‘Pick image from library’ node to get the image, because ‘Pick files’ node can’t open Photo Albums on iPhones to select multiple images. Running the App both on 2.4.24 runtime and on AppGyver Legend gives me the same error on my both android phones, a Galaxy S8+ and a Redmi Note 7 even with pictures taken from Camera.

Hi! I tried on iOS 2.4.27 with Pick Image from Gallery + Convert to base64 combo and had no issues. Are you still experiencing problems?

Thank you @Mevi, checked out and it worked. Maybe my mistake. Sorry.

This was still an issue, and was fixed in the 2.5.7 update. :slight_smile:

1 Like