Issues Passing Data from Input field to Airtable using PUT request

Hi,

I am having problems updating a record on Airtable using PUT. I have watched videos read here on the board and for some reason I cannot fix this and it is driving me up the wall. I love AppGyver but I cannot crack this one.

Using Airtable - I have setup and successfully tested Get record collection, get a single record and I can update (put) in the data setup and test environment. I can also get a record and display it in the app - both the data collection (used for dropdown using MAP) and single record that I want to edit and then update using PUT.

But this is where the problem starts - when I try to update the record using PUT, it works perfectly as long as I don’t try to include the content of an input field. If I only use the output of the dropdown (selected value which points to the Airtable record ID) and e.g. some true/false toggle fields - everything works. So herewith I think it is proven that the data source setup is successful.

So I basically have two problems:

  1. I cannot update and put anything to airtable that comes from an input field, which I need to do. I read the value from airtable, display it in an input field, edit it but sending it back to airtable via PUT doesn’t work.

  2. What I also can’t get to work is put everything as an object (I have tried different versions of a currentCountry page variable - text, object etc - all fails) - I have to put each input and toggle field separately using custom objects - like this (which as mentioned works, if I don’t try to include data from an input field):

Don’t pay attention to the fields with no value assigned - just me experimenting - it is understood that they all have to be assigned.

The updating of the data is triggered by a button:

image

The configuration looks like this:

image

Why can’t it store the output of an input box (seems to have type text/number vs text but converting the page variable into a multitype text/number doesn’t work - makes it incompatible)

Finally, I am (clearly) not a developer - just trying to build a proof of concept very very quickly for a startup, so learning as I progress. Your help would be greatly appreciated

Hi, I’m not familiar with Airtable but I’ll take a stab at trying to get you forward with this. If the multitype doesn’t seem to work, you can try binding it via formula, and that should work. In general I would definitely try to use page variable instead of the input value directly in the PUT function.

I would have the page variable be text type only, and then bind the input field’s value to the page variable (or if having tried this doesn’t work, then open the input field in isolation mode and bind the onchange event after a debounce node to set page variable, where you set the value).

But first of all I would just to test out try to do the PUT with static text in the fields where you would want the inputs in. Another thing you could try is making a data variable to pass in the Record properties instead, and tie this data variable into all the proper fields. The data variable would be in my opinion the “right” way to do this, but I think the other ways should work as well, but there might be a bug.