Issues with Push Notifications

Hey AG community,

I’ve been banging my head against the wall trying to figure out why I’m having so many issues with iOS push notifications.

I’ve set it up in two places and neither seems to be working.

  1. Is upon initial sign-up - it goes straight to REQUEST NOTIFICATION PERMISSION and then GET DEVICE TOKEN.

  1. I have a flow function later on in the app that after a button tap CHECKS NOTIFICATION PERMISSION and if they are not enabled flows through to REQUEST NOTIFICATION PERMISSION then to GET DEVICE TOKEN.

It works fine in AppGyver preview app prompting me to enable notifications, but once I test the build on iOS the flow fails silently. There is no prompt to test notifications and it also fails even if I have test flight notifications enabled.

I followed the setup tutorial and created my provisioning profile and distribution cert after enabling the push notifications functionality in my Apple App Dev account.

Any idea on what may be causing the error?

1 Like

Have confirmed this is an issue on BOTH Android & iOS. Neither is prompting enable notifications

1 Like

Thanks for letting us know. We will look into this. Sounds like a really annoying bug so sorry for inconvenience. I’ll let you know when we find the issue

1 Like

I tried the newest update to the request notification permission and check notification permissions and on iOS it flows through but still doesn’t prompt a request for notifications. At least it is no longer getting stuck.

Should I be putting a delay node in my logic or should I be storing the outputted return.

Have yet to test it on the standalone Android build as the latest runtime update 1.9.20 erased all of my configuration settings and now I can’t remember my Keystore password… :cry:

Could you try uninstalling and installing the app again? It might be so that the push notification permissions are kind of declined because the old version of the Flow function didn’t work properly and I think on iOS apps aren’t allowed to ask multiple time for permissions, but user would need to enable those in settings instead. With a fresh install the Flow function should work now, but let me know if even that doesn’t help.

And about the missing configurations settings: That shouldn’t happen. Could you give me your app ID so we could take a look if we can spot the issue that caused this or to revert your configurations back to the way they were pre-update?

Thanks @Tomi_Laakso

I’ll see if that works. I’m wondering if it has to do with Test Flight’s prompt for notifications and if that is what is causing the issue with the stand alone build. Will follow up once I"ve had a chance to thoroughly investigate.

The app ID is: 97782

Thanks so much! It would be great if we could revert back to the old build config for android!

We checked this now, but couldn’t see any issues. I can see all your configurations in the build service when I check it myself. Could you confirm that all is good or that there are still issues?

@Tomi_Laakso Yes still having issues. As I mentioned I tried reconfiguring it and now every build has failed. What you see are the misaligned configuration in the settings.

Can you reinstate the configuration settings before the last runtime update?

Hi, I checked how our system specifically works and unfortunately we don’t have backups of the old build service configurations. So I’m unable to reinstate your configurations to previous state, sorry :pensive:

(We think we found the issue why your configurations weren’t visible when you checked those after the update or at least one possibility for it. It’s just that UI didn’t show any indication that the data wasn’t loaded yet when for some reason loading was slow. We’re planning to update this behaviour, so this sort of issues wouldn’t happen again.)

Hey @William_Glass, are you still facing some issues with this one?
There has been some updates to the push notification documentation since our last reply, so just wanted to let you know that. And of course feel free to ask if there is still something that is not working. :slight_smile:

1 Like

@Kristian_Gerkman thanks for the follow up.The issues are with the request notification permission and get device token logic nodes not working once placed in an actual build. They work fine on the preview app (presumably because AG has these permissions already from Apple & Google), but they do not work on the standalone builds still.

If there’s a way to test this or perhaps I’m missing something that would be great. If you’d like to take a look the app ID is: 97782

Our backend is setup for push notifications we just aren’t able to get the device tokens in the standalone builds to actually implement them.

Request notification permission works silently in the background for some reason.“Get device token” works for me and i currently push notifications well in the 1.9.20 runtime, still waiting for 2.X issues to be resolve in order to test it however DO THIS - create a separate page and run the logic with only the main things and post it as a test. If you use Postman you can always test the notifications there.

Thanks for sharing @Nicole_Whiskie

Are you using this on web, iOS, Android, or some combination?

I’ve been having issues with Android & iOS standalone builds. They work fine in preview apps but in testflight and then on the Google Play store I run into issues.

Hey @William_Glass, I’m not totally sure if you have Get device token somewhere else other than the ‘My Challenges’- page. But if you don’t, then you might have forgotten to save the token to the deviceToken app variable that you are using in the next flow function. And if you do have another page with notification flows, could you point me to that page, I’d like to take a look at that. The flows on the ‘my challenges’ page look otherwise good. :rocket:

1 Like

I use android standalone. Create a test page and try it out may be something in the logic.

1 Like

Thanks @Kristian_Gerkman. I put that button there just to test the flow.

The main notification logic is on the On-Boarding page. It’s the final button submit where we request notification permissions.