List in HTTP Request

Hi friends, I’m trying to send a list of texts to Bubble using HTTP Request. But it is returning the following message:

{“statusCode”:400,“body”:{“status”:“INVALID_DATA”,“message”:“Invalid data for field destino: [1669492882741x522642495453528060,1669492891347x852110465073152000,1669492897755x692118216943861800] cannot be parsed as a JSON”}}

I am trying to send a list of ID’s.
I already checked in the JSON documentation that I need to group the list items as follows:

“cars”:[“Ford”, “BMW”, “Fiat”]

Below my HTTP Request:

You can see that I already inserted the [ in the request body, but I can’t insert the " " in each item of the list.

If anyone can help me, I’ll be forever grateful.

remove the brackets since I believe your dynamic pageVars ‘destino’ is already your list.

At first I didn’t insert the square brackets, and it showed the same error.

Just to help, I did the test in POSTMAN and it worked with " ":

If pageVars.rota_final.destino is a list, 100% you don’t need the brackets.
But you could try also by just removing the double quotes.

Forgot to mention, yes, the variable is a list.

in postman it didn’t work without the double quotes

But here it says List_destinos whereas in your formula you are using rota_final.destino.
Just use the correct list.

oops, sorry. rota_final.destino is a list that receives the list List_destinos

Ok so yeah destino is your list of text containing your IDs. It’s a dynamic value that is already a list so brackets not needed.

I achieved. I didn’t know how to enter the double quotes while creating the list. I tried like the image below:


I used the double quotes inside the single quotes and it worked. But I had to do it while inserting it in the list, I couldn’t format it just when sending it.

I entered a text just to accompany the list and I was able to confirm.