Loading data through an API. Will not appear in my app

Hi guys,

I use simple API which gets data from a third party. I then use the “set app variable” action and pick the right variable of the API to be set as the right variable for the app variable (with the get record option).

It all seems to work nicely, though, for some reason, the data does not seem to appear in my app.

I cannot debug the whole thing, as my android app keeps crashing. Can someone help me with some basic errors I might be making?

Can you share some of the details or screenshots of your Data Configurator setup for the API call? If you have run the “Test” for the API in the data configurator and Set the Schema then I would be interested in the type of data (i.e. String, Number. Boolean,…) you are trying to assign to your app variable.

Also, I use an Alert to display the whole “get record” item that was retrieved to make sure I am getting the data I would expect.

Let me know any additional details and I am happy to help further.

I’m back :stuck_out_tongue:

I got certain variables loading in currently, but others not. Using the same API, same source, only difference is the exact variable I GET.

I setup the whole flow like this:
image

Currently, it only displays PartnerBio1, but PartnerBio10 is left on empty (although in the source it has clear and distinct content and both variables are set up the exact same way). What is wrong here?

image

Hmm… Not sure what’s going on here, would need more info to sort this out. Are you still experiencing this issue?

It’s solved. It turned out to be a 501 error, so I played around with the source and it worked!

1 Like