Mac Version Issue

My Mac is Mac OS X 10.15.7 and is having trouble opening the mac app. Is there something else I need to do?

Hi,
Could you provide more context to the problem? Is there any error that pops out when you try to open it?

Yes

Hi,
I have checked and it looks like the lowest supported Mac OS version is 11.x (Big Sur). So your error comes from the fact that you have 10.15.7 installed.

You can use the web preview freely, but the app will require you to update your system.