Minimum Date Picked Not Limiting Dates

Hi there,

I’ve utilized the date picker component and when I attempt to set a minimum date using the formula function NOW() it doesn’t work. I’ve also got an AppVariable NOW that updates every 1 second and tried binding it to that as well. Neither works for the minimum value and I don’t want a user to be able to pick a date in the past.

Any idea how to sort this out?

Try NOW("YYYY-MM-DD") to format the datetime given by NOW() to just date format. It should work with that.

But yea, you’re right, it would be better/simpler if just using NOW() would work. I’ll see if we can make some fixes to the component.

1 Like

Thanks @Tomi_Laakso that did the trick!

I think an even better upgrade to the component would be actually removing the previous years from being viewable versus just unable to select them. Same on the other side of the spectrum from a max date perspective, limiting the future years from view.

I’ve used apps that take that approach on date selection components and creates a seamless experience with that component.

Yes, agreed :+1: I’ll keep this in mind until our backlog has a little more room

1 Like

Hi,

I am also trying to set it with fixed dates, but it is not working on iOS.
image

Additionally I am trying to set the initial value with:
FORMAT_DATETIME_LOCAL(ADD_DURATION(NOW(), 90, "days"),"YYYY-MM-DD")

But this also does not work on Android and iOS. Any ideas?

Hi @Kerem_Sevimli, if you check out the docs or hover over the little info label, you can see that the input is a text and not a datetime – just remove the DATETIME() function and it should work :slight_smile:

Hi @Mari thank you but it still not working on iOS. It was working also with DATETIME on Android. Now I removed the Datetime and only using text, again only on Android it is working.

And the initial Date does not work for both platforms.

Any ideas?