My app don't build!


Error: yargs supports a minimum Node.js version of 12. Read our version support policy: https://github.com/yargs/yargs#supported-nodejs-versions
    at Object.<anonymous> (/Users/ec2-user/.nvm/versions/node/v10.13.0/lib/node_modules/ynpx/node_modules/yargs/build/index.cjs:1:57378)
    at Module._compile (internal/modules/cjs/loader.js:688:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:699:10)
    at Module.load (internal/modules/cjs/loader.js:598:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:537:12)
    at Function.Module._load (internal/modules/cjs/loader.js:529:3)
    at Module.require (internal/modules/cjs/loader.js:636:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Object.<anonymous> (/Users/ec2-user/.nvm/versions/node/v10.13.0/lib/node_modules/ynpx/node_modules/yargs/index.cjs:5:30)
    at Module._compile (internal/modules/cjs/loader.js:688:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:699:10)
    at Module.load (internal/modules/cjs/loader.js:598:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:537:12)
    at Function.Module._load (internal/modules/cjs/loader.js:529:3)
    at Module.require (internal/modules/cjs/loader.js:636:17)
    at require (internal/modules/cjs/helpers.js:20:18)

Hi @Marcio_Soares, are you using the latest runtime version (2.10.2) to build your app?

in fact, I can’t look at it. it’s the first time i try to use appgyver and i fell in love with the tool, but when i tried to create my apk it showed this error. I didn’t know it used settings from my own machine.

Hi, I mean which choice did you make here for the runtime version in the build service? The error sounds like you might have chosen 1.9.26, which is there only to support apps built before our 2.x release.

image

I’ll to try newly. But I’ll do this…

Oops, it worked. thank you very much my darling. I really didn’t pay attention to the runtime version.

1 Like