Only certain apps cannot get a device token

I don’t know if it’s a bug, but I can’t get device tokens for certain apps only.
We only have one test device, so we have not been able to verify this on other devices.
If you would like, could you please download and check the following URL?
Also, if this is a problem with the app alone, can you fix it?
The app ID is 236371.

https://play.google.com/store/apps/details?id=com.appgyver.kokokitaM.app

Can you please help me?

I know the AppGyver team is busy, but could you please respond?

I have posted this many times.
The appgyver preview gets the token without any problem, but when I build it and download it from Google Play Store, I get the attached error in the token acquisition flow.

@Harri_Sarsa
I have posted this several times.
I’m sorry to bother you, but I’m having a lot of trouble here.
I can’t get a device token for one app, even though I can get one for other apps.
I have tried publishing DATA and PAGE in the marketplace and copying them to another app, but the same error occurs.
Token acquisition failure → 249812 236371
Successful token acquisition app → 236975

Is there any other way to get the token other than getdevicetoken?

Translated with DeepL Translate: The world's most accurate translator (free version)

Hi @takuya_akama, apologies for the long response time! Have you tried using the “Get Firebase device token” flow, does it also fail for the app?

@Mari
I am very happy to hear back from you.
It didn’t work.
Is it possible that only certain devices can’t get it?
I checked the Android settings, etc., but I don’t think there is a problem.
Is there some kind of flow that is preventing me from getting it?
I’ve tried everything I can, but I can’t seem to get it to work.

Hi, there shouldn’t be anything in the app to prevent that from happening, so it is probably a device issue. Which device are you testing on?