Page and app variable updating became selectively unstable

@Harri_Sarsa or @Mari, do either of you have thoughts on this? It started over the weekend. I’ve spent the past couple weeks testing the app myself and am just about to start testing it again with friends and family, except that these new bugs have popped up.

These remind me of last July when sometimes buttons didn’t work on cheap phones because the page had so much on it that it didn’t render correctly…but I could be totally off base there. I’m just hoping this is something that can be addressed. I’ve been working on my app on AppGyver for 8 months now (had to start again from scratch halfway through) and I know it’s so big it’s crashing the previewer. If it sounds like this can’t be fixed for some reason, please let me know.

I created two tracked bugs with links to videos where I show these issues I’m encountering:

Here’s a video showing the first issue: https://youtu.be/PEpNv0jKLP8

I’m having trouble with the previewer right now, so I actually can’t say whether the problem is that it won’t update the variable, or that the variable updates but then isn’t accessible to the bound text…?

This is app 173781 page 24. DM me on the forums and I can give you a link that signs you into the app so you can test it yourself. (ErinHWagner)

Second bug: I use my own authentication system. The login box’ visibility is bound to a page variable. This video shows how the variable doesn’t seem to update correctly:

It also shows that when it starts misbehaving, the input fields bound to app variables also stop working.

I believe the bug in this additional video is also related: https://youtu.be/kPkWoWkcMQY

I noticed that on the login page, when it’s malfunctioning, it’s showing two items whose visibility is bound to a page variable–but one is set to show when the item (which is boolean) is true, and the other is set to the opposite. But they’re both showing at the same time.

In this video, it’s showing all items that are linked to page variables regardless of the variables’ values. It’s also not updating checkbox values that are linked to app variables.

This is app #173781 on page 36.

Hi! As answered on our tracker, we’re currently looking into issues like this and hopefully they will get fixed in 2.6.X versions, once those are ready to be released.

1 Like

@Harri_Sarsa @Mevi @Mari

Hi Team!

I wanted to circle back on this issue to see if you guys had any additional thoughts. I built the app using the 2.6.3 runtime, and the exact same issues still occur. The issues haven’t changed over the past month, which I think is probably a good thing because it means there’s a specific bug in there somewhere, not just a nebulous performance issue.

I’ve been doing my best to buy you time to work on the new runtime, but with the app being at a standstill for more than a month, I have run out of other things to do. I learned about test automation, build out a separate admin app for managing data, did a bunch of housework and even visited family. But my fellow entrepreneurs are raising their eyebrows at my project having ground to a halt, and I have to admit they have a point.

So I am now, regrettably, learning to code. I would absolutely love if you guys could swoop in and save me from this unsavory destiny. Do you think you could take some time to look at what has caused my app to implode (stop updating variables)?

Great news! The illustrious @Kristian_Gerkman reached out this morning, and my issues all appear to be fixed thanks to his debugging and your recent runtime update. I’m leaving in half an hour to get my COVID vaccine, but I’ll be focused now on wrapping up my testing. If anything new arises, I’ll be sure to let you know.

omg, if this means I don’t have to learn to code, I will be sooooooooooooooooooo relieved!!!

2 Likes

Hi!

My core app continues to perform perfectly. Thank you again! Now, I might be seeing this same visibility issue on a second app. I created a video demonstrating the issue here:

In summary: I have a button that should show a spinner, execute a bunch of steps, then hide the spinner and a component. When previewing, it does everything except hide the component. When fully deployed, it won’t even show the spinner (the first step). I have tried putting the “hide component” step into various places along the route. I have also tried deleting out and creating nodes from scratch. No luck so far though.

What is the best way for me to proceed? @Kristian_Gerkman, I’ll DM you login credentials just in case that’s helpful in troubleshooting.

This is app #310454.

Once again, @Kristian_Gerkman got me all set. He said there were two bugs behind it, but he told me some easy ways to design around them.

In case anyone else hits this, here were the takeaways:

  • Don’t use the show/hide spinner functions if you’re building a web app. Instead, build your own spinner and show/hide just that component. In this case, it doesn’t have to be fancy, so I just replaced it with a long “updating” toaster.
  • Within repeating components, don’t use show/hide component. Instead, tie components’ visibility to a boolean page variable and update that variable.
1 Like