POST not working as expected

While trying to create a reporting screen I ran into an issue similar to the thread here: Math formula doesn't want to give the correct output - #8 by Ashley_Mclean

For content, in the attached image you will see my 5 steps. All page variables are saved as text, because I get an error posting the data when it is not a text type.

So here is the issue, for the last week everything for this app has worked well. It has been GETting data, and POSTing data without any issues. All of a sudden yesterday it stopped working (everything did). I cant even do a simple POST any more. I have tried in two different browsers, and even tried clearing cookies/cache.

The problem is I cant POST to a specific collection. I am using Firestore, and I can post and read data from 15-20 different collections. I just did a successful post from another page in my app as well. I am using the exact same formatting from the other pages, and I am in the same project. Why is this only not working for this one collection (in the same project)?

I see the “does the server allow CORS” error in Chrome, and when loading the page I get this error with the get record on all pages in the app, even though it is still retrieving the user id from firebase.

WHen getting the record:
has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. If an opaque response serves your needs, set the request’s mode to ‘no-cors’ to fetch the resource with CORS disabled.

When posting: generic 400 or 404 error.


@Mevi please help me! Your tutorials are great :smiley:

Can anyone help with this? Its the “Priorities” page in the app @Harri_Sarsa