Preview crashing, builds not working - Please help!

I have been working on my app since 5 month and am ready for the public beta.

2d ago made some small UI changes, all was ok and visible in Preview. Then all of sudden builds started to fail (iOS & Android). And now also the preview app is crashing when loading the app.
→ I tried to rollback the app but still the preview is crashing.

Is my app somehow corrupted? Please help, as I need to release my public beta!

Runtime: 2.8.33
AppID: 210914

Just realised that the „Updated x minutes ago“ indicator in the Preview app always stays at „0 minutes“

Maybe the app code is not updated properly?

I treated the Preview app on iOS and Android, both crashing.

1 Like

Hey @Sonke_Petersen, I checked your app and I can’t see anything that jumps out as problematic, and the app is also crashing for me - I did notice that the initial page was somehow bugged, so I tried changing it and then changing it back, but that didn’t help

It’s most likely something on your global canvas App launched event. I didn’t yet look much deeper in to this. Do you mind if we try to find the crash by “disabling” (disconnecting some flows) some logic and then putting it back together once the issue is found?

It also could be something UI related, but it happens immediately after you open the app, so it’s more likely to be something logic related.

Hi @Kristian_Gerkman , thank you for looking into this!

Sure, you can disconnect some logic flow to see if it helps. Anyway, I did not work on the global canvas since some time and everything worked well so far.

My last changes have been at the affiliate page and some theme vars.

Thank you again, crossing fingers!

Any news on this?

I tried to disconnect the Logic from Global Canvas and also deleted the whole page which I edited before the bug. But the App Preview and Builds are still crashing.

Kind of stuck here

it seems not your app, because my app also … fewer hours preview runnging well but now it show global canvas page ( not showing aniything just loading ) compiled build also error on runtime ( appgyver subdomain and even my own server

mine also

interestig, it seem connected with me disabled global navigation
after enabled it again my app preview run well and build also

Tried the same here (Enabling global navigation). Also changed the startpage etc.

But still crashing :frowning:

Hi @Kristian_Gerkman do you have any news on this? The app is still crashing in preview and builds have an unknown error.

There is nothing I can do here and we are directly before Beta release after months of work.

Hope you can debug the project in AppGyver side?

@Kristian_Gerkman sorry for pushing here again, but it has been 3 weeks since I am waiting for support.

I know you guys are busy and (unfortunately) we do not pay a monthly fee for AppGyver Support. But if nobody from your side is helping when an app is corrupted we all here have a high risk using AppGyver.

Come on guys, any update on this?

I send mails to your support and try to get help in this forum.

  • P l e a s e h e l p *

5 month of all hard work do not work anymore

Do you have any update on this?