Preview error on the platform

Hi, I was using the platform normally when suddenly my app stopped working. My last build works normally on my own host but my current version does not work on preview web or Android, with the following error:

26 Jun 17:08:09 - [info] nodes.flows.started-flows
bundle-1592836465501.js:126 Error during service worker registration: TypeError: Failed to register a ServiceWorker for scope (‘https://preview.appgyver.com/undefined/’) with script (‘https://preview.appgyver.com/undefined/service-worker.js’): A bad HTTP response code (403) was received when fetching the script.

I rolled back to a version that I’m sure it was working and it is still the same thing. Status page says everything is up.

Update: the URL on network tab is Request URL:

https://preview.appgyver.com/undefined/service-worker.js and it is getting (failed)

net::ERR_INVALID_RESPONSE

Now the build created is also having the same problem. I tried to run another app that I have just started two weeks ago and it has the same problem.

I discovered what was the problem.

For some reason, the navigation button that lead from the initial screen to the main one was broken. It was written “Empty” on the node, even though it was correct on the setup. I changed to another screen and it did not work. It only worked after I deleted this node and created all over again. I’m not sure why it happened.

From the beginning: my preview app crashed with a red page. And then it was no longer working. I did a rollback that would only remove a new page, not the main one.

The service worker error still happens and it is not the cause.

1 Like