Preview opens suuuuper slow as of just a few minutes ago

Maybe 10 minutes or so ago, my previewer started loading really slowly. I was afraid a change I made was slowing it down, so I disconnected all the page logic. It still took 59 seconds to load.

Anyone else getting this?

This has turned out to be a pretty big problem for me today. Sometimes, it hasn’t loaded at all. I’m trying to troubleshoot a formula that’s giving me trouble, but it’s 1-10 minutes of waiting every time I need to pull it up, with the occasional break to do a chore around the house because it just isn’t working.

I had originally stuck with the Legend previewer because I was having infinite wait problems with the 2.X previewer. I’m hoping (reeeaally hoping) this resolves quickly. I’m pretty much dead in the water.

Sometimes on the preview app I get the message: “Network error. Retrying to download the app descriptor.”

@Harri_Sarsa , @Mevi , do you think someone might be able to help me with this?

Last week, I realized that if I got the previewer to open, my new changes would load quickly as long as I did not re-open the previewer, so I was just extra careful to not close that window once it was loaded.

Unfortunately, I haven’t been able to get it to open at all today. I’m on minute 13 of my fourth try, and it’s just spinning forever:

I’m using the latest version of Chrome for Windows. This is my only open window, and the only tab is the Composer. I did an internet speed test and am at 48mbps upload and 19mbps download. I tried opening a smaller app I have, and that worked fine. I also tried opening my big app on Edge and was not able to open my app preview there, either.

I’m beginning to fear that my app is simply too big for me to be able to open the previewer. This would be quite the punch in the gut, having put 8 months into its development and being on the brink of launching my beta :frowning:

Would one of your engineers be willing to maybe hop on a call with me and help me identify what elements I could take out that would make the biggest difference? Or is there another way I can go about this? It isn’t opening on the debugger, either.

Note: I’m trying to open Gomigo V3

Note: I was able to get it to open by closing Composer so the previewer was the only window open and re-opening the app in the previewer. I’m still pretty nervous though because I’m not done building out my app. Would love to gain an understanding of what the upper limit will be.

Well, that didn’t quite work, either. It didn’t update after I did my first change. I have been trying to reload it now for 9 minutes with no luck.

It eventually loaded last time and I was able to confirm that my previous change had worked. But then I made another change and it didn’t update and wouldn’t load. I stepped away for a few hours and am trying again now. I’ve been waiting 15 minutes and it still hasn’t loaded. :cry:

I don’t know how to use the browser’s Inspect element at all, but I figured there was no harm in poking around. Is this a clue?

I closed that one and tried again. A few minutes in, I got this:




I tried running it 10 more times. 9 times, it returned those console errors after 1 minute. (The 5th time, it gave the error after about 20 seconds.)

It worked for a little while. (The resets are when I saved in Composer and the preview refreshed itself with the update.)

Thanks for the detailed updates and investigation, looking at this now!

1 Like

I wonder if this problem of my app being too big is also behind the flow chart lines displaying strangely:

Now that I think about it, I think that started at about the same time that my previewer access became less stable.

I too have noticed all my flow function wires have gone berserk…

We couldn’t repro the error you were having, though the app is very big and it’s uncovering areas where optimization is needed on our end… Let us know if the problem still persists.

The flow function wires issue is something we’re aware of and trying to pin down (hard to get a solid repro), seems to not affect app functionality though, and is unrelated to this issue here.

@Harri_Sarsa It has been working well this morning which I suppose is good for me for now but bad for you for reproducing the error :slight_smile:

I’ll ping you here the next time it happens for sure. Are there any bits of data you would like me to gather for you?

For the record, I’m noticing that today the console isn’t showing any errors when I save in Composer and the previewer restarts itself:


(as opposed to yesterday during the period where it would reload but would throw a reset error–that screenshot above)

(Oh shoot–I wrote this up yesterday but apparently never hit ‘send.’ Better late than never, I suppose.)

I didn’t have any problems at all today until right now. Right before it failed, I was testing a feature that relied on a new api call which had a bug. I fixed the bug and saved in Composer. Instead of the previewer refreshing itself, it failed. Maybe a bad api call brings about the error?

I just hit my first error today:

It was working until I changed a ‘set app variable’ node. The variable is an object, and I was setting a property within that object.

I was testing it on mobile and after working a handful of times, it stopped loading despite several tries there. I wasn’t able to find a way to ‘inspect’ my mobile browser, so I tried it on desktop and got this.

For the record, I have an LG V20 running Android 8.0.0 (it’s a cheap phone). The browser was Chrome 88.0.4324.181.