Project Won't Open and just Stuck on Loading


My app has 11 pages, and starting few days ago it will load and open after about 30 minutes…but tried opening today it’s more than 1.5 hours and still loading.

Tried both Edge & Chrome browser yet it won’t open.

App ID: 552063:

Are there any AppGyver activities/maintenance might be causing this?


I’ve been saying this a lot recently, but do you use conditional renderers? If so, check and make sure that you don’t use more than one per page. That will either near-infinite loading or reversion back to an initial page (in the case of an auth system).

Mind you, I’m not sure if you’re referring to opening in the web preview, or if you mean the editor itself. This specifically refers to the preview.

Hi Dominik,

Thanks for your reply and advice.
And sorry for the confusion, i mean opening in the editor.

I actually use conditional renderers and most of my pages have two. Since it helps me during ui creation and specially when editing components. And i don’t think i’ve seen from the forum talking about negative issues with conditional renderers, that’s why i have no idea of this side effects.

Anyway, I’ll just reduce these renderers to 1 per page.

Thanks agaiin for the help!

If it works for you with multiple ConRens, perhaps, you don’t have to change anything. Just maybe something to keep in mind if you ever have trouble loading pages with multiple of them in the web preview.

It’s just a problem I first noticed in late 2021 and, just yesterday, I was investigating why a profile page couldn’t be loaded. Had a leftover renderer in the Tree and removed it. Problem fixed. Mind you, I’m testing web apps in the web preview. May be different for mobile apps.

As for Composer (editor), I’m uncertain what could be the problem specifically. Is your editor fully up-to-date? In other words, no available update number inside the Marketplace button on the left side of Composer? I haven’t experienced long load times in a good two years. Is there any other information that is displayed that might give an idea?

If it’s on both Chrome and Firefox, it probably is Appgyver side, but you could try purging your browser cookies. Does it happen immediately after signing in – which I have to do every time I open the editor.

Yes, I think its better not using too much ConRens to not affect performance.

My editor is updated. it’s my first time having this editor loading issue since i started using appgyver last year.

And also, i don’t delete cookies when signing in since i have no problem opening my appgyver projects before. Just started doing it today when you mention it.

As a work around to continue working the app, i download a copy of the project then i create a new project by uploading the downloaded copy. I do these every time i’m having the loading problem. Sometimes the loading is shorter but most of the time its too long.

My other simple and short apps/projects are loading okay and not taking too long. I also tried creating a new appgyver account, but still having the same issue.

Shortest loading time i guess was around 20 mins., sometimes it goes beyond 45 mins and i’ll stop waiting and will just create a new project. To save time, i will create two projects at the same time with my two accounts using edge and chrome for each account. Then whichever opens first will be the one i continue working with.

And i tried removing the cookies when i sign in just as you suggested, this somehow helps and shortens the loading time but not all the time.

Below are the screenshots of the error i’ve seen on the console.
The second one shows up sometimes when i created a new project from the downloaded copy.

Anyway, thanks so much for sharing helpful information.

App ID: 552063

App ID: 562678

1 Like