Properties not fully updating when new data source chosen

Just wanted to make sure the devs were aware: When I created a note to update a record, it defaulted to one of my configured data sources.

When I switched it to the data source I needed to update, it added the new source’s properties, but it also retained all of the properties for the original data source with no way for me to remove those.

(In this case, the node defaulted to the data source Groups, and I changed it to UserActivities.)


Actually, it turns out this is a functional problem for me. The PUT endpoint is only expected 4 properties, and so it’s accepting the Group data source’s properties (name & allMembersInvite) instead of the correct UserActivity data source’s properties.

Also, in order to get rid of the spot where it asks for the groupId as a parameter, I added userId as a parameter on the data source, even though it isn’t actually required. At that point, the system stopped asking for the groupId because it had something to substitute in.

When I configured and tested the PUT in the data source, it worked just fine, so I’m thinking this is a bug in the new layout…?

Hi! Just wanted to see if anyone had thoughts on this issue. I’ve tried workarounds like copying Update Record nodes from other parts of the app, but whatever the original data source was, the binding editor retains those properties.

If I understood and reproed your issue correctly, you can just change the binding type in the binding editor to No value and the property will disappear.

1 Like

Woohoo! Gotta love an easy fix. Thank you, @Tomi_Laakso!

For posterity: It turns out the required properties that were missing weren’t getting pushed out by the obsoleted properties. They weren’t showing up in the PUT because I had the binding incorrect.

1 Like