Reading Data Variables that include Child Records - does not seem to be working

I have a child record included in my GET from a REST API and it is shown in the test read. It is also shown in the config page when I assign it (so it is clearly being recognised)…but when I go to the app via the iPhone app and view it - nothing is displaying??

I have tried to feed it into a page variable to display it… still nothing. Can anyone tell me why the child record is not being shown?

Here is a look at the data structure from the GET…

image

Hi there!

This is a known issue that we should be resolving soon. Meanwhile you should be able to work around it by binding the property with a formula instead.

Thanks for the suggestion. I tried binding the priority to a formula of the child record, but it still comes through blank on the property. Any other suggestions on what I may be doing wrong?
Thanks!

Another possibility is that the live data has become different from the stored schema.

The editor just uses the stored schema, so check from the data resource “test” tab that you’re indeed still getting the data you expect.

Hi - yes, I am still getting the data that I expect when I run a a test on the data… any other ideas?