ReferenceError: Can't find variable: Buffer

Hi,

I am getting the following error on my ios phone. I have tried it with the preview on the web and it works perfectly.

Is there a dependency needed for ios apps?

Please see error below when trying to upload it to the Firestore server.

I have read the feed about “ReferenceError: Can’t find variable: Buffer” but it isn’t helping because it is currently working on the online preview within appgyver.

Hi,

what’s the logic you’re trying to run when this error appears?

I know you saw the topic here and at least in that one it seems the user was trying to pass information in the wrong format. Please check all your bindings in the relevant logic that they don’t complain e.g. that you need an Object or a String for something.

Hi Mevi,

I am trying to create a record in the firebase database:

I have created a record on the client device.

The structure on the client side and firebase side are the same and I can’t find any differences, not sure if I am missing something.

On the preview side online it works when doing it from a MacBook but when I try the preview app it gives the ReferenceError.

Please see screen shots below:

This is the output from the preview app:

This is the logic:





The client side is:

Screenshot 2021-09-02 at 09.24.58|690x387

So do I understand correctly that the part that is failing is the Create Record of order_cloud? What are you passing as value to the create record flow function, if that is where the error comes from?

Hi Mevi,

This is correct. I am passing it directly from the get record. I have also used the formula and that is also giving the same problem.

I have also tried doing them individually with “Object with properties”
But it also gives the error.

One thing I have had a look at is a nmp dependancy. its called buffer. Not sure if this is the reason for the problems I am experiencing?

@Mevi Please let me know if this is something to do with my logic or if it is the buffer aspect issue?

@Mevi , Please any help will be greatly appreciated. I do not know which way to go with this error.

Hi @Ashley_Mclean our developers have identified the likely cause of the issue and made the fix, but deploying it might still take a bit of time. Apologies for the inconvenience and thanks for your patience!

1 Like

Happy for spending 2 hours on this forum after 7 hours of troubleshooting stuff to find out that it is a bug… :smiley:

Hi Mari,

Please can you give me a rough ETA on when the new bug fix will be deployed?

Kind regards

Hi @Ashley_Mclean, according to my latest information the fix should be deployed in a couple days’ time.

2 Likes

Oh I just stumbled upon the same mistake and looking forward to the fix! <3

Hi Mari, Please let me know if this has been deployed because I saw an update over the weekend but the problem still persists my side.

Kind regards

1 Like

@Mevi please can you let me know ETA for the update with bug fix?

@Ashley_Mclean ETA is this Wednesday, our apologies for the wait!

Thank you Mari

I am looking forward to it

:smiley:

1 Like

Hey, Its working now :grin:

1 Like