Request failed with status code 403

Keep getting this error on a particular app. Didn’t have any problems since last build (many months ago).

Runtime version: 4.2.12; AB version: 1.6.4 {“message”:“Request failed with status code 403”,“name”:“AxiosError”,“code”:“ERR_BAD_REQUEST”,“config”:{}}

Does anyone else have this problem? Is there a fix?

Hi,
Do you have any custom assets added via a link? For instance a custom font:
image

All the assets are downloaded when the app is queued for the build, thus a connection error points to builder being unable to fetch the data.

If not, please move this issue to https://tracker.appgyver.com/ and provide your appID for easier investigation (see: Issue reporting guidelines)

Hello Kirill,
I have 2 fonts uploaded manually. They appear correctly on preview app on both platforms.
I’m not pulling anything via link except rest api connections.

Feel free to check the app if you have time
“199805”

Hi,
Your issue is present due to a 404 response on the very first data resource.

Kirill thank you for guiding me. My fault.
Do you think it is possible in the future to implement a more guided error explanation upon building the package? At least for beginners that don’t know where to look in the first place.

Thanks again

1 Like

Good point! This is in our development pipeline.

Most common errors are explained here: SAP AppGyver FAQ.

1 Like

Kirill can you please have another look because i still get the same error. I triple checked the data connections with a get test method and everything returned ok status.
Your help is much appreciated. Thank you!

Hi,
Pages 9 & 10 are not working in the preview. That is probably why the build is failing.
Could you please go through every image and check every page that it is working as intended?

I deleted both these pages, even duplicated the app just in case, but still on both occasions I get the same error.
Is there a way to see the error on debugging maybe?

I have checked the debugger, but there weren’t any errors (it only shows if the flow functions and events work properly). You have to check that all Image URLs, web page URLs and etc are available. This error means that one of the external assets is not available.

Thanks again Kirill. I’ll check all links and assets.

Kirill, it was a font which was not available for download when I tried to download it locally. Removed that and everything was good to go.
Thanks for your help. :slight_smile:

1 Like

Glad to hear it worked out! Good job on the app, it looks amazing :slight_smile:

2 Likes

Thanks :grin:
Im working on it and its getting better day by day.