REST API works in the Configurator, but not in the app

Hi guys,

I have this GET API which works fine and all in the data configurator.
Though, when I want to use it in the app, it returns no value at all.
I check what values are returned by using an alert which uses the record of the GET call as the message.
The alert stays blank, just like the app variables that are set, based on the output of the GET record.

Screenshots below:

It all works well in the data configurator
image

This is how it looks on-page, when the page mounted

image

As you can see, for test purposes, the id here is the same as in the data configurator

image

Though, there is no output at all, the app variables are not set (although they’re connected to the output of the GET record as I always do)

Hi, what’s your app ID? What environment does this happen in? Android/iOS/web, which preview app version (you can check that by clicking on your email address in the preview)?

So, the app crashes completely on my mobile app when I start the app (that’s another problem actually)

This is in the app preview portal on my laptop

Okay – one thing you can do is to check for any network errors in Chrome inspector, you can open it when running the app in web preview by right-clicking on the page, choosing “Inspect” and going to the Network tab. There you can see all the network requests your app makes and their status.

I can also take a look at the logic flows if you provide me with the app ID. It’s found in the URL in Composer.

thanks Mari, wil check that inspector.

The app ID is 180985

It does not seem to request anything at all. I’ll check in with the trigger for this flow (although the alert in the flow does show up)

Good catch! Let me know if you need any further help :slight_smile:

Well, it seems like the flow is activated though (as i do get the alert that is registered after the GET request). How could that be?

Hi @jordan_vd_berk, I got access to your app so I can check what’s going on here. How do I find the right flows?

@Mari Great!
So, it’s on page “introduce yourself” (page 14), flows activate in logic of page load

Hmm, these bindings at least look like they point to some node that doesn’t exist anymore:

image

Yeah, very strange, cause they should exist. There are a lot of nodes by the way (in total >200?)

This happens if you for example delete the original Get record node, then the subsequent node (Set app variable) loses context of what is the “previous node”. You need to update the bindings so that they refer to the updated node every time you make some changes.

Btw, I bound the content of the alert message to the output object of Get record, you should now able to see there not only if it has passed but what’s come out of it:

Alright, I’ve been experimenting a bunch, so indeed, there was no up-to-date node anymore. Let me get back to you asap

So, I now do get the alert to show me all the GET record input, but it still does not set the app variable I want it to set. Though, the alert after the app variable is set also shows up (basically indicating that it should have worked. But it did not, cause I do not see it showing up anymore)

image

Hi, did you get the app variable to populate? :slight_smile: I was thinking that the issue might be related to only setting values to a few of the app variable’s many fields, you could maybe try using a formula instead of the binding editor.

1 Like

Hi! Yes, it is all solved. I basically copied the data resource and it worked there. Very odd, but for now it’s fine I guess :wink:

1 Like