REST data source RUN TEST no longer working

For many of the data sources of my app (ID 95001) testing the data API no longer works. The button for get collection is grayed out, all these used to work last week just fine. It could actually be that there is something else wrong as well as the data is not updating via these data sources in the app any more. Testing the same app via Amazon AWS own tools shows that the API and access work properly still.

Also tested this with another app of mine, same problem. No RUN TEST with a parameter works (was fine yesterday).

This is kind of critical problem… (also did a bug report already as well).

Thank you in advance!

1 Like

i have the same problem !

Add some screen shots, show what you have done. Whats the api etc.

i cannot click the test button to set the schema from response

Same problem for me, get collection is working fine

Me too :slight_smile:

Me too have this problem!

Yep, having the same issue. Cannot run a test on any REST API.

is anyone in AppGyver looking into this bug? This is critical. All development is being hindered by it. Please expedite a resolution to this problem.

Hello, ran into this issue and found a workaround/fix. Rather than define the request schema in the “Config” tab, manually set the Request Schema in the “Schema” tab

Hey all,

This bug is currently under review and should be fixed soon, you can follow its status here: REST data source TEST no longer working (critical) | Voters | AppGyver

Sorry for the inconvenience in the meantime!

2 Likes

I think I encountered this one the other day too. This was caused when the URL placeholders in the API call were set to mandatory (ie. “Is optional” is set to off.)
image
image
A temporary workaround (at least for me) was to is to temporarily set the placeholder’s “Is optional” property to on. This allowed me to run the test, then set the schema from the response.
image
image
Once that’s done, you can change the properties back to NOT optional. I’m not sure if this is helpful to anyone else right now, but it worked for me.

1 Like

I had the same problem.

I found a solution for that.

  1. Inspect the RUN TEST button

  2. Change the disable=“disable” property to enable

Done!

2 Likes