Set variable to void doesn't work anymore in App (works in Web)

When I want to clear my input, I set the variable to an empty value.

It works perfectly on Web and Preview on Web, but it doesn’t in Andoid App.

The entry stay with the value in Andoid App.


It should work, but try if setting the page variable via formula to "" would work better instead :thinking:

Already tried with same result.

I also tried to put something in the variable (for example the word “test”); In the web works fine and put the “test” word in the input but not in App.

it just happens in the app version. I click the action button to set the variable to empty (to clear my search input) and nothing happens.

Same problem, does work on Iphone preview but not on Android…

1 Like

Hmm, the only case I’ve found so far is that if the input field is focused, and page variable is emptied, the input field does not empty until after it is not in focus (= user clicks elsewhere). Is this the behaviour you’re experiencing?

Hey @Mevi , this is exactly what we are experiencing. As I mentioned in my thread similar to this, we do have a real-time chat. So the expected behaviour is after sending a message the input field would be emptied even though is in focus. However, this is also a question of how does the focus works, because it seems that clicking on a button doesn’t lose focus on the input.

Example: You have an input field and a button next to in. You type something in the input field and click on the button (here should be focus on the input field lost, right?).

Yep, I reported this as a regression bug. The fix is currently scheduled for 3.3.X release :pray:


Lovely. Any ETA on that, please? I can see that 3.2.X is out even though there’s no info about it in the changelog, so I guess 1-2 weeks?

Thanks for the note on our changelog, seems a step in the process was missed in our recent release hurry!

As for 3.3.X, 1-2 weeks is a pretty good estimate, but of course delays may happen.

1 Like