Show Google maps in app using webview

I created a webview in my app to view Google maps.
Maps starts in the app without problems, but when I click on the button “Navigate in app” then I get two error messages!



Can anyone help me with that?

Can anyone please help me with this issue?

I think your problem there is you are trying to open an app from inside your app, which you cant do.

Hi John,
Thanks for your reply.
Ok, but when I use the same URL in chrome in the mobile, then everything works as it should.
How can I launch the Google Maps app from my app?

Hi! You need to forward that url from inside the webview into an “open url” flow function and then I think it should work. Not sure if that’s possible right now, but you could try if the events the webview fires would give you the information you’d need.

Hi Mevi,
Thank you so much for your response :slight_smile:
I test and get in touch!

Hi Mevi,
Unfortunately I have never used “Flow Functions” and do not know how to do!
I tried but did not succeed :frowning:
Can you please explain how I should do to solve my problem with it?

I read on Internet that many people who build apps with Andoid studio have had the same problem as I have and solved it using Intent. So, it does not work via Web view
Is there anything I can do with Appgyver and how?
I want to launching Google maps app from my app that I built with Appgyver!
My app is very dependent on google maps and needs to get started as soon as possible.
Grateful for any help

Here you can find our introduction to flow functions :slight_smile:

Hmm, I tried doing this and didn’t even need to use a flow function? But I tried just plain https://maps.google.com and when it came time to navigate it automatically opened the google maps app (on iPhone). But it seems you’re using Android so it might just be a difference of the platforms.

Still, the gist of what you should try is using the “onLocationChange” of the webview and see if you could open that url with the open URL flow function.

Another option is to use the embedded map view component instead of webview, have you checked that out yet?

1 Like

Thank you Mevi for your answer and your suggestions :slight_smile:
I test and get in touch!

Hi Mevi,
I have tested with open URL and it works really well :slight_smile:
Thank you so much for your help.

1 Like