[Solved] iOS build failed with this error

Hi All

Can someone please advise on this? I have been unable get ios build.

I can pick up the error below from the log , but not sure how to proceed. Any assistance will be much appreciated. Thanks in advance.

1 error generated.
** ARCHIVE FAILED **
The following build commands failed:
CompileC /Users/administrator/Library/Developer/Xcode/DerivedData/RNVApp-fyfcitoxfwyvcdaoahjbkhswosdc/Build/Intermediates.noindex/ArchiveIntermediates/RNVApp/IntermediateBuildFilesPath/RNVApp.build/Release-iphoneos/RNVApp.build/Objects-normal/arm64/RNPhotoEditor.o /Users/administrator/app-builder/STAGING/client/platformBuilds/app_255090_ios/RNVApp/RNPhotoEditor/RNPhotoEditor.m normal arm64 objective-c com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)

Forgot to mention that I’ve put your issue to our backlog and we’ll investigate it. I’ll let you know when we find the issue and have a fix for you available.

Hi @Tomi_Mustonen

I go this right eventually

I removed the following components from my app and it worked so I’m not sure which one causes the build to fail

  • Rich text editor
  • Open browser
  • Video player

Thanks

Great to hear you got it working :+1: And thanks for letting us know the potential causes. Those helped us to pinpoint the issue to Rich text editor. It’s now on the backlog so hopefully we’ll have a fix for it soon.

This also means you should be able to add Open browser and Video player back to your app.