Something strange: components are not showing the data

Hi folks.

Something strange is happening that I really can’t understand.

I’m pretty sure to have done all the necessary steps.
I tried to capture in a video all the steps I made. By the way I’ll describe them below.
https://youtu.be/K0QlIjf7TxY

  • I made an API call throught the data section which retrieves correctly the data.
  • In the composer I made the connection with this api call
  • I create a new composite component with properties that get data from outside.
  • Composer show up correctly the data retrieved
  • Preview not shows the data but it seems that it’s creating the repeated component

Am I doing something wrong?

Which composite component?
How did you bind the data to that component? (any screenshot?)

How do you manage to see this?

Hi @Fred_Kuzyk thanks for the reply.

Actually I made my own custom composite component.
Hi binded the data via composite component’s properties.


As you can see from the screen below, composer shows data from the previous api call.

But I don’t see them in preview as shown below

I’m no expert with editing such composers. They are tricky to setup.

What you see in the preview does not seem to be “data” but just default values.

To figure it out, you could dissect an existing component that is similar so you compare the properties and find out what may be missing or not well setup?

I’m afraid my help stops here, sorry.

What you see in the preview does not seem to be “data” but just default values.
Ok, yes, you are right! I did not figure out that.

By the way, I’ll try to build a new page with new component.

I have already made other composite components and I never got that issues.

I will update you guys about this.

1 Like

[UPDATE] I did build a new page with a composite component from the marketplace and it displays nothing.
But it works with simple component like a label.
After I have done this last I tried to bring the custom component into the new page and now it works!!
Bahh

1 Like