Stretch to the viewport height doesn't work after update to 2.10.2

Is someone else having a problem with “Stretch to the viewport” option after update to 2.10.2?
I have a full screen design app and everything worked well on version 2.8.33, but after update client runtime version to 2.10.2 I found out, that iOS build has safe area displayed. I created a bug report.
Maybe this is related with a problem Disable Scroll/Full-page scroll views not functioning properly?

You know, you may be right. It seems to be a blend of, both, Disable Scroll and Stretch to Viewport Height not functioning. Not only do we have the white gap at the bottom of some of our web app pages (Stretch), but our custom headers aren’t working working correctly either (Disable Scroll).

Hey, @Mari, Krisu said something on Slack three weeks ago about a lot of the AG team being on vacation, which is fine. But again, that was three weeks ago. Any chance you know when the general crew will be back in to take a look at these things, if at all. Seems to be just you and Krisu now.

Hi @Petr @Dominik_Greene – thanks for your messages, we’re looking into this issue.

My apologies for the slow response time on here lately, the whole team has been very preoccupied after the acquisition – we do sometimes pick up bugs from the forums without having much time to follow up on the threads themselves, so stuff might already be worked on in the background. We’ve got some reinforcements back this week, so communications should be improving. :slight_smile:

I appreciate the update, @Mari!

Ever since the acquisition in February-ish, it sure did seem like things were slowing down. Less team engagement on the forums, less announcements and updates, and the Tracker barely touched/updated (by the looks of it), and now, in the last month, things breaking down in Composer and no acknowledgement of it by the team – which seems to be running a skeleton crew lately. With all due respect, it’s rather worrying. :confused:

Dear @Mari, thanks for the answer, hope the team will fix this bug as soon as possible because some users can’t update their apps due to this bug, for example, I can’t update my client’s app for 20 days. :frowning:

Hi! Unfortunately there’s nothing to be done right now – there will be a “disable safe area” checkbox in the same place as the “disable scrolling” checkbox, but that is under development this week and will need runtime support as well, so while it is not a huge thing to fix, it’ll take some time still before it will be available.

@Dominik_Greene yep, I’m afraid we most definitely have slowed down in the things that we are able to show/talk about publicly. We are gearing up for larger releases on both Composer and runtime side, and as such the releases that have been put out outside of them have had a lot less of our attention and less features etc. I understand your worry, but we’re still here – trying to hustle with our small crew to get big important features out :slight_smile:

1 Like

Thanks, @Mevi. Hey, we haven’t really updated our app too much in the last month. Was “Disable Scroll” breaking related to one of the three optional updates from about 20-30 days ago that users manually install? If so, we might be able to roll back that far without losing too much progress, which should take us back before it all broke down. We’d simply not install the new updates for a while.

Or is this all automatically pushed on the backend?

Thank you @Mevi for the clear answer. Hope you will be able to fix it soon. @Dominik_Greene already asked for the ability to roll back the previous runtime version, but I want to know if it is difficult to keep both 2.x versions together?

And I’ve already tried… The rollback/history timeline doesn’t extend far enough in my case to do so – only about 17 days to the roughly 20-25 I’d need to try. So back to square one there.

I’m not sure if I understood you correctly – did you mean by “disable scroll breaking” this safeArea on top of the screen when in no navigation bar mode, or is there another bug with disable scroll, not related to the safe area? (the light grey area below iOS status bar)

If the former, the safe area appeared in 2.7.0 and is in all latter runtimes. Unfortunately we can’t provide 2.6.8 for building as we have had to make changes in our infrastructure (for scalability and future features) that aren’t backwards compatible :expressionless:

@Mevi With the runtime version 2.10.2 as well as with the last Preview app safe area is appeared without changing the app layout. I have successfully built app on runtime version 2.8.33 without top and bottom safe area (I have the elements with absolute position -44px on the top and bottom respectively and this works before the last update. On another page I have the same elements with absolute position and -44px margins and this works as well before the update to 2.10.2. “Stretch to the viewport height” option doesn’t change anything. I can’t do anything to avoid those grey lines at the top and bottom. So something was changed after update from 2.8.33 to 2.10.2. On the screenshots you can see the difference.


@Mevi Hello, yes, the whole problem we’ve been having for about the last half-month is that we have our custom floating headers using the full-page scroll views (default nav header disabled) for our web app. It’s worked fine for months until a few weeks ago where now, it’s almost as if the scroll views no longer function because the whole page scrolls, including the floating header.
To use an old gif, this is what we wanted (floating header):
chrome-capture (2)

Now the whole page scrolls with the main browser scroller as though Disable Scrolling was not ticked and as though the scroll views do not exist. I am in the AG beta program which may have given me a broken release on that front, but that doesn’t seem to be the problem because a few others are having the same issue – unless they’re in the beta too. Either way, it breaks our floating headers and our custom pop-up screens.

Fingers crossed that you folks can roll back at least some code to make this work again or find a workaround.

Thank you,
Dom.
(Celebrating one year here now with a full day of work.)

@Mevi I’ve seen the “safe area” check box. That was only relevant to mobile devices.

Notable that the Disable Scrolling is completely non-functional for desktop web apps which breaks our “sticky” headers and custom popups. I’m not sure if there’s a plan to restore this at some point or to incorporate a formal sticky or fixed component positioning for desktop (like relative and absolute). Fingers crossed.
Screenshot 2021-09-09 081500

(Communicated through other channels but just putting here for visibility)

Previously this feature was only meant for iOS/Android, so web was only accidentally supported. We’re looking into this issue now and have some potential fixes coming in 2.12.2.

Hi @Mevi, any updates to “ignore safe area”? I have checked this option, but still have safe area visible in my app. Do I need to do something else in my app? As of now I have absolute position of top and bottom containers with -44px top and bottom margin or position respectively.
Thank you.

(This was discussed here and is solved in 2.12.4)