Suddenly my login isn't working on test app

So…I haven’t worked on or touched my app since last weekend. Everything was working fine then.
I just went to log in to the app tester on my phone and I couldn’t remember my password (I’d changed it), and I couldn’t log in. So I went to the forgot password link, put in my email–and nothing happens. No toast, and no email.

So then I went to create a new account, and after I fill in my info it tells me that my email is missing! I have NEVER had that happen before, and my email is filled in, and so is my password.

I can’t log in, can’t create a new account, can’t get a password reset…

I thought I hadn’t made any changes to the login, but I just looked at the history and realized I’d worked on trying to create a PersistedUser to keep users logged in unless they logged out. So i thought maybe that was the problem, and I did a rollback to that point, and tried the test app again, and I still can’t get in.

When I went to work on the app and looked at the forum, I had to refresh the forum because it had been updated. Can that have anything to do with this? I don’t understand why suddenly none of my login works on the test app.

Please help!

Hi Cheryl, sorry to hear! Are you still experiencing this issue? What’s your app ID?

Thanks, Mari. (smiling at you) Yes, I’m still having the issue. I don’t know if it’s a bug or (more likely) something I did, but it’s never happened before. My app ID is 188232

Thank you,

Hi Cheryl, when you are using web preview to test the app in Google Chrome, you can right-click on the browser window, choose “Inspect” and open the “Network” tab, where you see all the HTTP requests you’re sending from your app and their status. Checking it this way, I keep getting a 400 error when trying to sign up or log in to your app:


A 400 Bad Request error means that the request the client made is incorrect or corrupt, and the server can’t understand it. The main thing to understand is that the 400 error is a client-side error . It indicates that the request the client submitted can’t be processed by the server.

To resolve this, I would double-check that the request you’re making is formatted according to what the API that you are using for logging in is expecting from you.

Hi Mari (smiling at you),
Thank you. It was all working before.

So…just now I went to Appgyver. I was going to take screenshots of the way we had things set up so i’d know how they were…and the site told me to update 5 components, saying that I hadn’t, including an http request component update. I updated the 5 components, then tried to log in on my app–and suddenly it worked! I then tried to create an account–and suddenly I could. The app is allowing me to log in again!

I did not change ANYTHING except for updating the 5 components as the site asked me to. So…could that have caused the problem? Or could it be from Firebase side? Either way, I am just so relieved it is working again. PHEW! Now I can work on my app again.

1 Like