The app buttons created in appGyver are not working in latest SAP Build Preview app but working fine in Appgyver Preview app

The app buttons created in appGyver are not working in latest SAP Build Preview app but working fine in Appgyver Preview app.and Appgyver Preview app is removed from appStore…Kindly help

Im having the same issue,

I already created a copy of my app and got the same error, please help

I do see the App preview in the Apple Store and it works correctly.

Same here, see screenshots comparing android previewer vs. android standalone:

1 Like

Hi @Jose_Alberto_Iglesia ,
Currently SAP Appgyver preview app is not there in app store only SAP Build apps in present in app store. The button shown below is not working (even though you click it won’t take you to next page)in Sap build apps preview app but the same button is working in my colleagues mobile who have SAP Build apps and who have not updated their app . But there is only option available in playstore / appstore.

I am having the exact same issue. I have a login page that works in the preview web app. But when I build the app and upload it to my website, the login button does not work at all. It is not even sending a api call to my backend to authenticate the user

I also have issues with the current SAP Build App. Clicking on a button does not open a new page. This worked before and I did not change anything.

Hi there. My problem earlier is fixed. All I had to do was make sure all my flow functions are up to date on the market place. then everything worked all right on my new build. Hope this helps.

Missing items in list controls. All controls are updated. This problem is specifically in newest Android version only. The ios and web preview function as intended but android one has become unreliable.IOS and web app shows 8 items in my list which is correct but android preview app shows only 1 item in the list.

These bugs are only after updating to the latest version of app preview.

The generated app build works fine. Thr issue is with preview app only.

1 Like

Hi @lorenzo_Naidoo,

Could you please help with this process. My buttons are still not working


Check that there are no updates pending for your app by clicking on the Marketplace and looking under Updates tab.

Check that the button still has the logic attached.

Check that the button is not disabled (Disabled property under Properties).

Check if the problem also happens in web and if it does, check what error comes up in network tab. If it’s 403, it’s authentication related.

Try these out and let me know if these help!

EDIT: found out there’s a problem with navigation flows in 4.7.X if native navigation is disabled. Set native navigation to enabled in the mean time to continue development

1 Like

Hi @Mevi ,

  1. There are no pending updates on the market place
    2.The button has the logic attached
  2. the button is not disabled
    4.This problem is not happening on web

This app was earlier working fine on SAP Appgyver Preview App on both iPhone and Android but it’s not working on SAP Build Apps Preview App and also where to enable native navigation?

@Mevi ,
Also when these problems will be fixed in Build Apps Applications ? Any ETA?

@Lohitha_Maddipoti the issue with navigation disabled making navigation flows not work is fixed in next runtime release. You can disable/enable navigation from the navigation tab in the top bar.

sure , @Mevi Thank you!

I also faced this same issue but it is fixed now

  1. I installed the updates from marketplace.
  2. Please check navigation logic for button, in my case “open in modal” inside inputs was set to false which I changed to true and it started working.

@Mevi when will the next runtime release be available? This is still an issue for me and enabling native navigation didn’t fix it. Any info you can provide is greatly appreciated

Hi! Sorry for the belated answer. The web version with the fix is already out so you can try it!

Hi Mevi, the SAP Build App is still not working when I try to preview, both in the app and web, any info you can provide to solve this? it shows a eternal spining loading wheel…

Hello Matias,

Can you send some screenshots of it? How it is and how it should be, in a couple builds back i had the same issue, i just updated some flow function in a button and it came back to normal!